summaryrefslogtreecommitdiff
path: root/pcr/python2-rosdistro/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python2-rosdistro/PKGBUILD')
-rw-r--r--pcr/python2-rosdistro/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/pcr/python2-rosdistro/PKGBUILD b/pcr/python2-rosdistro/PKGBUILD
new file mode 100644
index 000000000..05333a402
--- /dev/null
+++ b/pcr/python2-rosdistro/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=python2-rosdistro
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="A tool to work with rosdistro files"
+url="http://wiki.ros.org/rosdistro"
+depends=('python2')
+makedepends=('python2' 'python2-setuptools')
+license=('BSD3, MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/r/rosdistro/rosdistro-$pkgver.tar.gz")
+md5sums=('2d8ac4214796e67c758a1318b6531b4f')
+
+build() {
+ cd $srcdir/rosdistro-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/rosdistro-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}