summaryrefslogtreecommitdiff
path: root/pcr/python2-rosdistro/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2015-04-30 08:25:19 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2015-04-30 08:25:19 -0500
commit003dcbe501634144f128c783ea8758e6f62ace39 (patch)
tree49da229594826ccc61b3603ae1e1c6e2887eb5da /pcr/python2-rosdistro/PKGBUILD
parent507594a8116cb97a57ec303d7fd55398bfaa6530 (diff)
downloadabslibre-003dcbe501634144f128c783ea8758e6f62ace39.tar.gz
abslibre-003dcbe501634144f128c783ea8758e6f62ace39.tar.bz2
abslibre-003dcbe501634144f128c783ea8758e6f62ace39.zip
python2-rosdistro: add new package to [pcr]
Diffstat (limited to 'pcr/python2-rosdistro/PKGBUILD')
-rw-r--r--pcr/python2-rosdistro/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/pcr/python2-rosdistro/PKGBUILD b/pcr/python2-rosdistro/PKGBUILD
new file mode 100644
index 000000000..05333a402
--- /dev/null
+++ b/pcr/python2-rosdistro/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=python2-rosdistro
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="A tool to work with rosdistro files"
+url="http://wiki.ros.org/rosdistro"
+depends=('python2')
+makedepends=('python2' 'python2-setuptools')
+license=('BSD3, MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/r/rosdistro/rosdistro-$pkgver.tar.gz")
+md5sums=('2d8ac4214796e67c758a1318b6531b4f')
+
+build() {
+ cd $srcdir/rosdistro-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/rosdistro-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}