summaryrefslogtreecommitdiff
path: root/nonsystemd/dbus/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/dbus/PKGBUILD')
-rw-r--r--nonsystemd/dbus/PKGBUILD63
1 files changed, 34 insertions, 29 deletions
diff --git a/nonsystemd/dbus/PKGBUILD b/nonsystemd/dbus/PKGBUILD
index 565beb0e6..c8f7d2084 100644
--- a/nonsystemd/dbus/PKGBUILD
+++ b/nonsystemd/dbus/PKGBUILD
@@ -1,40 +1,33 @@
-# Maintainer: David P. <megver83@parabola.nu>
-# Maintainer (Arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
-# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
-# Contributor (Arch): Tom Gundersen <teg@jklm.no>
-# Contributor (Arch): Link Dupont <link@subpop.net>
-
-pkgname=dbus
-pkgver=1.12.20
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Link Dupont <link@subpop.net>
+
+pkgbase=dbus
+pkgname=(dbus dbus-docs)
+pkgver=1.14.0
pkgrel=1
-pkgrel+=.nonsystemd2
+pkgrel+=.nonsystemd1
pkgdesc="Freedesktop.org message bus system"
url="https://wiki.freedesktop.org/www/Software/dbus/"
arch=(x86_64)
arch+=(i686 armv7h)
license=(GPL custom)
depends=(libx11 libelogind expat audit)
-depends+=(libelogind.so libaudit.so)
makedepends=(elogind xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive)
-provides=(libdbus libdbus-1.so)
-provides+=(dbus-elogind dbus-openrc)
-conflicts=(libdbus dbus-elogind dbus-openrc)
-replaces=(${conflicts[@]})
source=("git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
dbus-enable-elogind.patch
- no-fatal-warnings.diff
- dbus-reload.hook
- dbus.initd)
+ no-fatal-warnings.diff)
sha256sums=('SKIP'
'faffcaa5b295f49fcedeed2c9ece5298949096be3062fd99a4bf1a6ac3ad1ea0'
- '6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e'
- '1335a86bb5eb68614bf13af314f1a7f5f6f68253584986e9c5b492a4585ab722'
- '9964aa935b4a7d64f5970bcfcd561b06013a85ae2712444bc4c5f644364dab3b')
+ 'c10395be67e1127a58d7173b587fbbf16f8a8b271c41293558fcf9e27c185478')
validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
prepare() {
cd dbus
+
patch -Np 1 -i ../dbus-enable-elogind.patch
+
# Allow us to enable checks without them being fatal
patch -Np1 -i ../no-fatal-warnings.diff
@@ -48,6 +41,7 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--libexecdir=/usr/lib/dbus-1.0 \
+ --runstatedir=/run \
--with-console-auth-dir=/run/console/ \
--with-dbus-user=dbus \
--with-system-pid-file=/run/dbus/pid \
@@ -67,10 +61,15 @@ build() {
}
check() {
- make -C dbus check
+ make -C dbus -j1 check
}
-package() {
+package_dbus() {
+ depends+=(libelogind.so libaudit.so)
+ provides=(libdbus libdbus-1.so)
+ conflicts=(libdbus)
+ replaces=(libdbus)
+
DESTDIR="$pkgdir" make -C dbus install
rm -r "$pkgdir"/{etc,var}
@@ -79,14 +78,20 @@ package() {
echo 'u dbus 81 "System Message Bus"' |
install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
+ # Split docs
+ mkdir -p doc/usr/share
+ mv {"$pkgdir",doc}/usr/share/doc
+
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
+}
+
+package_dbus-docs() {
+ pkgdesc+=" (documentation)"
+ depends=()
- # Remove docs
- rm -r "$pkgdir/usr/share/doc"
+ mv doc/* "$pkgdir"
- # Init script
- install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
- install -Dm755 "$srcdir/dbus.initd" "$pkgdir/etc/init.d/dbus"
- install -d "${pkgdir}/etc/runlevels/default"
- ln -sf "/etc/init.d/dbus" "${pkgdir}/etc/runlevels/default/dbus"
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
}
+
+# vim:set sw=2 et: