summaryrefslogtreecommitdiff
path: root/~lukeshu/parabolaweb-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~lukeshu/parabolaweb-git/PKGBUILD')
-rw-r--r--~lukeshu/parabolaweb-git/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/~lukeshu/parabolaweb-git/PKGBUILD b/~lukeshu/parabolaweb-git/PKGBUILD
new file mode 100644
index 000000000..9b2614ed8
--- /dev/null
+++ b/~lukeshu/parabolaweb-git/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+
+pkgname=parabolaweb-git
+pkgver=20111204
+pkgrel=1
+pkgdesc="The Parabola website, fork of archweb"
+arch=('any')
+url="https://projects.parabolagnulinux.org/parabolaweb.git/"
+license=('GPL2')
+depends=('python2' 'git'
+ 'django=1.3.1'
+ 'python-markdown=2.0.3'
+ 'python-south=0.7.3'
+ 'python2-pyinotify=0.9.2'
+ 'python-memcached=1.47'
+ 'python2-pytz>=2011n'
+
+ 'python2-psycopg2'
+)
+install=parabolaweb.install
+
+# These will make it install into /http/srv/web
+_install_dir=/srv/http
+_gitname=web
+
+_gitroot=https://projects.parabolagnulinux.org/parabolaweb.git
+_gitbranch="master"
+
+build() {
+ sed -i \
+ -e "s|^_install_dir=.*|_install_dir='$_install_dir'|" \
+ -e "s|^_gitname=.*|_gitname='$_gitname'|" \
+ -e "s|^_gitroot=.*|_gitroot='$_gitroot'|" \
+ -e "s|^_gitbranch=.*|_gitbranch='$_gitbranch'|" \
+ ../parabolaweb.install
+}
+
+package() {
+ install -d "${pkgdir}/${_install_dir}"
+}
+
+# vim:set ts=2 sw=2 et: