summaryrefslogtreecommitdiff
path: root/~lukeshu/emacs24/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~lukeshu/emacs24/PKGBUILD')
-rw-r--r--~lukeshu/emacs24/PKGBUILD85
1 files changed, 0 insertions, 85 deletions
diff --git a/~lukeshu/emacs24/PKGBUILD b/~lukeshu/emacs24/PKGBUILD
deleted file mode 100644
index f9eb76d64..000000000
--- a/~lukeshu/emacs24/PKGBUILD
+++ /dev/null
@@ -1,85 +0,0 @@
-# $Id: PKGBUILD 137977 2011-09-13 15:26:07Z juergen $
-# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
-# Contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
-pkgname=emacs24-bzr
-_majorver=24.0.92
-pkgver=106756
-pkgrel=1
-pkgdesc="The extensible, customizable, self-documenting real-time display editor"
-arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/emacs/emacs.html"
-license=('GPL3')
-depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'gtk2' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib')
-makedepends=('bzr')
-install=emacs.install
-source=(emacs.desktop)
-md5sums=()
-
-_bzrtrunk=bzr://bzr.savannah.gnu.org/emacs/trunk
-_bzrmod=$pkgname
-
-build() {
- cd "$srcdir"
- msg "Connecting to Bazaar server...."
-
- if [[ -d "$_bzrmod" ]]; then
- cd "$_bzrmod" && bzr --no-plugins pull "$_bzrtrunk" -v -r "$pkgver" 2>&1
- msg "The local files are updated."
- else
- bzr --no-plugins branch "$_bzrtrunk" "$_bzrmod" -v -r "$pkgver" 2>&1
- fi
-
- msg "Bazaar checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_bzrmod-$_majorver"
- cp -r "$srcdir/$_bzrmod" "$srcdir/$_bzrmod-$_majorver"
-
- cd "$srcdir"/$pkgname-$_majorver
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --with-x-toolkit=gtk --with-xft
- make
-}
-
-package() {
- provides=("emacs=${_majorver}a")
-
- cd "$srcdir"/$pkgname-$_majorver
- make DESTDIR="$pkgdir" install
-
- # remove conflict with ctags package
- mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
- mv "$pkgdir"/usr/share/man/man1/{ctags,ctags.emacs}.1.gz
- # fix all the 777 perms on directories
- find "$pkgdir"/usr/share/emacs/$_majorver -type d -exec chmod 755 {} \;
- # fix user/root permissions on usr/share files
- find "$pkgdir"/usr/share/emacs/$_majorver -exec chown root:root {} \;
- # fix perms on /var/games
- chmod 775 "$pkgdir"/var/games
- chmod 775 "$pkgdir"/var/games/emacs
- chmod 664 "$pkgdir"/var/games/emacs/*
- chown -R root:games "$pkgdir"/var/games
-
- # fix FS#9253
- mkdir -p "$pkgdir"/usr/share/pixmaps
- ln -s $pkgdir../emacs/$_majorver/etc/images/icons/hicolor/48x48/apps/emacs.png "$pkgdir"/usr/share/pixmaps/emacs-icon.png
-
- # This is done down here to help future-proof the above
- rm "$pkgdir"/usr/bin/emacs
- mv "$pkgdir"/usr/share/man/man1/emacs{,-$_majorver}.1.gz
- for prog in ctags.emacs ebrowse emacsclient etags grep-changelog rcs-checkin; do
- mv "$pkgdir"/usr/bin/$prog{,-$_majorver}
- mv "$pkgdir"/usr/share/man/man1/$prog{,-24}.1.gz
- done
- mv "$pkgdir"/usr/share/applications/emacs{,24}.desktop
- mv "$pkgdir"/usr/share/emacs/site-lisp/subdirs{,.emacs24}.el
- rm "$pkgdir"/usr/share/info/dir
- for file in "$pkgdir"/usr/share/pixmaps/emacs-icon.png `find "$pkgdir"/usr/share/{icons,info} -type f`; do
- mv "$file" "`echo "$file"|sed 's/\..*/-24&/'`"
- done
- ln -s "$_majorver" "$pkgdir"/usr/share/emacs/24
- rm "$pkgdir"/var/games/emacs/*
-}
-
-md5sums=('bc513345deb65f0e910f43c1a74072de')