summaryrefslogtreecommitdiff
path: root/~fauno/haskell-tagsoup/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~fauno/haskell-tagsoup/PKGBUILD')
-rw-r--r--~fauno/haskell-tagsoup/PKGBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/~fauno/haskell-tagsoup/PKGBUILD b/~fauno/haskell-tagsoup/PKGBUILD
deleted file mode 100644
index 0de1f165b..000000000
--- a/~fauno/haskell-tagsoup/PKGBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-# custom variables
-_hkgname=tagsoup
-_licensefile=LICENSE
-
-# PKGBUILD options/directives
-pkgname=haskell-tagsoup
-pkgver=0.12.3
-pkgrel=1
-pkgdesc="Parsing and extracting information from (possibly malformed) HTML/XML documents"
-url="http://community.haskell.org/~ndm/tagsoup/"
-license=("BSD3")
-arch=('i686' 'x86_64')
-makedepends=()
-depends=("ghc=7.0.3-2"
- "sh"
- "haskell-bytestring=0.9.1.10"
- "haskell-containers=0.4.0.0"
- "haskell-text=0.11.0.5")
-options=('strip')
-source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-install="${pkgname}.install"
-sha256sums=("8bed50b3958a794422563ad93d82fb6d4e806d1884623f35f454ff360d9b8138")
-
-# PKGBUILD functions
-build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
-
- runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
- --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup haddock
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
-}
-
-package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 ${_licensefile} ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/${_licensefile}
-}