summaryrefslogtreecommitdiff
path: root/~fauno/haskell-citeproc-hs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~fauno/haskell-citeproc-hs/PKGBUILD')
-rw-r--r--~fauno/haskell-citeproc-hs/PKGBUILD60
1 files changed, 0 insertions, 60 deletions
diff --git a/~fauno/haskell-citeproc-hs/PKGBUILD b/~fauno/haskell-citeproc-hs/PKGBUILD
deleted file mode 100644
index 32f06094b..000000000
--- a/~fauno/haskell-citeproc-hs/PKGBUILD
+++ /dev/null
@@ -1,60 +0,0 @@
-# custom variables
-_hkgname=citeproc-hs
-_licensefile=LICENSE
-
-# PKGBUILD options/directives
-pkgname=haskell-citeproc-hs
-pkgver=0.3.3
-pkgrel=1
-pkgdesc="A Citation Style Language implementation in Haskell"
-url="http://gorgias.mine.nu/repos/citeproc-hs/"
-license=("BSD3")
-arch=('i686' 'x86_64')
-makedepends=()
-depends=("ghc=7.0.3-2"
- "sh"
- "haskell-http=4000.1.1"
- "haskell-bytestring=0.9.1.10"
- "haskell-containers=0.4.0.0"
- "haskell-directory=1.1.0.0"
- "haskell-filepath=1.2.0.0"
- "haskell-hs-bibutils=4.12"
- "haskell-json=0.4.4"
- "haskell-mtl=2.0.1.0"
- "haskell-network=2.3.0.2"
- "haskell-old-locale=1.0.0.2"
- "haskell-pandoc-types=1.8.2"
- "haskell-parsec=3.1.1"
- "haskell-syb=0.3"
- "haskell-time=1.2.0.3"
- "haskell-utf8-string=0.3.6"
- "haskell-xml=1.3.9")
-options=('strip')
-source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-install="${pkgname}.install"
-sha256sums=("249bc0ec589fc79b098867502732c3c47ce032ad32f82d3280c1ca9373c71f7a")
-
-# PKGBUILD functions
-build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
-
- runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
- --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup haddock
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
-}
-
-package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 ${_licensefile} ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/${_licensefile}
-}