summaryrefslogtreecommitdiff
path: root/pcr/rxvt-unicode-pixbuf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/rxvt-unicode-pixbuf/PKGBUILD')
-rw-r--r--pcr/rxvt-unicode-pixbuf/PKGBUILD97
1 files changed, 97 insertions, 0 deletions
diff --git a/pcr/rxvt-unicode-pixbuf/PKGBUILD b/pcr/rxvt-unicode-pixbuf/PKGBUILD
new file mode 100644
index 000000000..ce01efbcf
--- /dev/null
+++ b/pcr/rxvt-unicode-pixbuf/PKGBUILD
@@ -0,0 +1,97 @@
+# Maintainer (AUR): Jacob Steffler <jacobsteffler@gmail.com>
+# Contributor (AUR): Sébastien Luttringer <seblu@aur.archlinux.org>
+# Contributor (AUR): Angel Velasquez <angvp@archlinux.org>
+# Contributor (AUR): tobias <tobias@archlinux.org>
+# Contributor (AUR): dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+# parabola changes and rationale:
+# no changes.
+
+_pkgname=rxvt-unicode
+pkgname=rxvt-unicode-pixbuf
+pkgver=9.22
+pkgrel=2
+pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt), with support for custom icons and backgrounds'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://software.schmorp.de/pkg/rxvt-unicode.html'
+license=('GPL')
+depends=('rxvt-unicode-terminfo' 'libxft' 'perl' 'startup-notification' 'gdk-pixbuf2')
+optdepends=('gtk2-perl: to use the urxvt-tabbed')
+provides=('rxvt-unicode')
+conflicts=('rxvt-unicode')
+source=(
+"http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2"
+'urxvt.desktop'
+'urxvtc.desktop'
+'urxvt-tabbed.desktop'
+'font-width-fix.patch'
+'line-spacing-fix.patch'
+'https://gist.githubusercontent.com/alexoj/df5bae7a4825cb596581/raw/75a1e75c2ae1ec5c0db68a29f8a6821e9e3d87a5/sgr-mouse-mode.patch')
+md5sums=('93782dec27494eb079467dacf6e48185'
+ 'fec94dc986fa37ec380079d81de3e0b2'
+ 'fac55f0a8404c86dad3e702146762332'
+ '8a5599197568c63720e282b9722a7990'
+ 'df0c3a8b6bb0578d1b91e4081c47881c'
+ 'd4e03127a0d3bbf2e173850770651b08'
+ 'f8325b0a33999db4d5d1eeac4f320156')
+
+prepare() {
+ cd $_pkgname-$pkgver
+
+ patch -p0 -i ../font-width-fix.patch
+ patch -p0 -i ../line-spacing-fix.patch
+ patch -p0 -i ../sgr-mouse-mode.patch
+}
+
+build() {
+ cd $_pkgname-$pkgver
+
+ # disable smart-resize (FS#34807)
+ # do not specify --with-terminfo (FS#46424)
+ ./configure \
+ --prefix=/usr \
+ --enable-256-color \
+ --enable-combining \
+ --enable-fading \
+ --enable-font-styles \
+ --enable-iso14755 \
+ --enable-keepscrolling \
+ --enable-lastlog \
+ --enable-mousewheel \
+ --enable-next-scroll \
+ --enable-perl \
+ --enable-pointer-blank \
+ --enable-rxvt-scroll \
+ --enable-selectionscrolling \
+ --enable-slipwheeling \
+ --disable-smart-resize \
+ --enable-startup-notification \
+ --enable-transparency \
+ --enable-unicode3 \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-xft \
+ --enable-xim \
+ --enable-xterm-scroll \
+ --enable-pixbuf \
+ --disable-frills
+ make
+}
+
+package() {
+ # install freedesktop menu
+ for _f in urxvt urxvtc urxvt-tabbed; do
+ install -Dm644 $_f.desktop "$pkgdir/usr/share/applications/$_f.desktop"
+ done
+
+ cd $_pkgname-$pkgver
+
+ # workaround terminfo installation
+ export TERMINFO="$srcdir/terminfo"
+ install -d "$TERMINFO"
+ make DESTDIR="$pkgdir" install
+
+ # install the tabbing wrapper ( requires gtk2-perl! )
+ sed -i 's/\"rxvt\"/"urxvt"/' doc/rxvt-tabbed
+ install -Dm 755 doc/rxvt-tabbed "$pkgdir/usr/bin/urxvt-tabbed"
+}