summaryrefslogtreecommitdiff
path: root/pcr/qgis/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/qgis/PKGBUILD')
-rw-r--r--pcr/qgis/PKGBUILD119
1 files changed, 0 insertions, 119 deletions
diff --git a/pcr/qgis/PKGBUILD b/pcr/qgis/PKGBUILD
deleted file mode 100644
index 0d99e08d0..000000000
--- a/pcr/qgis/PKGBUILD
+++ /dev/null
@@ -1,119 +0,0 @@
-# Maintainer (Arch): Doug Newgard <scimmia at archlinux dot info>
-# Maintainer (Arch): XavierCLL <xavier.corredor.llano (a) gmail.com>
-# Contributor (Arch): SaultDon <sault.don gmail>
-# Contributor (Arch): Lantald < lantald at gmx.com >
-# Contributor (Arch): Thomas Dziedzic < gostrc at gmail >
-# Contributor (Arch): dibblethewrecker dibblethewrecker.at.jiwe.dot.org
-# Contributor (Arch): Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
-# Contributor (Arch): Eric Forgeot < http://esclinux.tk >
-# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-# Contributor: Isaac David <isacdaavid@at@isacdaavid@dot@info>
-
-# Globe Plugin and Map Server are disabled in cmake by default.
-# Uncomment them in the build() portion if you'd like them enabled.
-# You will also need to install osgearth-qt4 or fcgi, respectively, before building.
-
-pkgname=qgis
-pkgver=2.18.16
-pkgrel=1.parabola1
-pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats, without nonfree ElvenSword resource'
-url='https://qgis.org/'
-license=('GPL')
-arch=('i686' 'x86_64')
-depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'postgresql-libs' 'proj'
- 'qt4' 'qca-qt4' 'qjson' 'qscintilla-qt4' 'qwt-qt4' 'qwtpolar-qt4' 'spatialindex' 'sqlite'
- 'python2' 'python2-httplib2' 'python2-future' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
-makedepends=('cmake' 'gsl' 'perl' 'txt2tags')
-optdepends=('gpsbabel: GPS Tool plugin'
- 'python2-pyspatialite: Processing plugin'
- 'python2-yaml: Processing plugin')
-mksource=("http://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
-mksha256sums=('8989e0f9003cfec41ff6cf984bb52866dd0f4d97fe88ec2326f1cf1140050835')
-source=("https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.tar.bz2"
- "https://repo.parabola.nu/other/${pkgname}-libre/${pkgname}-libre-${pkgver}.tar.bz2.sig"
- "libre.patch")
-sha256sums=('ea4da40b19fe81c0fcece89a6d87a389e7f0a6f99964e0c33a88f91f0ffeb4a9'
- 'SKIP'
- '94c9457dc861a368edefb4fc8173471dbd2c4024b41346202d44d7aa7e03064e')
-validpgpkeys=('1B8C5E87702444D3D825CC8086ED62396D5DBA58') # Isaac David
-
-mksource() {
- cd $pkgname-$pkgver
-
- # remove nonfree resource
- rm -rv "resources/cpt-city-qgis-min/es"
-}
-
-prepare() {
- cd $pkgname-$pkgver
-
- patch -Np1 -i "$srcdir/libre.patch"
-
- # Make sure we find the -qt4 versions of qwt and qwtpolar
- sed -i '/QWT_LIBRARY_NAMES/ s/qwt /qwt-qt4 /' cmake/FindQwt.cmake
- sed -i '/PATH_SUFFIXES/ s/qwt$/&-qt4/;/LIBRARY NAMES/ s/qwtpolar/&-qt4/' cmake/FindQwtPolar.cmake
-
- # Fix references to "python"
- sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
-
- # Remove mime types already defined by freedesktop.org
- sed -e '/type="image\/tiff"/,/<\/mime-type>/d' \
- -e '/type="image\/jpeg"/,/<\/mime-type>/d' \
- -e '/type="image\/jp2"/,/<\/mime-type>/d' \
- -e '/type="application\/x-adobe-mif"/,/<\/mime-type>/d' \
- -i debian/qgis.xml
-
- [[ -d build ]] || mkdir build
-}
-
-build() {
- cd $pkgname-$pkgver/build
-
- cmake -G "Unix Makefiles" ../ \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DQGIS_MANUAL_SUBDIR=share/man \
- -DENABLE_TESTS=FALSE \
- -DCMAKE_SKIP_RPATH=TRUE \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DWITH_QTWEBKIT=FALSE \
- -DWITH_INTERNAL_QWTPOLAR=FALSE \
- -DWITH_INTERNAL_{MARKUPSAFE,OWSLIB,DATEUTIL,PYTZ,YAML,NOSE2,SIX,FUTURE}=FALSE \
-# -DWITH_SERVER=TRUE \
-# -DWITH_GLOBE=TRUE
-
- make
-
- LD_LIBRARY_PATH="$PWD/output/lib/" make synccrsdb
- mv /tmp/srs.db ../resources/
-}
-
-package() {
- cd $pkgname-$pkgver/build
-
- # Add optional deps based on selected or autodetected options
- [[ -n "$(sed -n '/^GRASS_PREFIX:/ s/.*=//p' CMakeCache.txt)" ]] && optdepends+=('grass6: GRASS6 plugin')
- [[ -n "$(sed -n '/^GRASS_PREFIX7:/ s/.*=//p' CMakeCache.txt)" ]] && optdepends+=('grass: GRASS7 plugin')
- [[ "$(sed -n '/^WITH_SERVER:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('fcgi: Map Server')
- [[ "$(sed -n '/^WITH_GLOBE:/ s/.*=//p' CMakeCache.txt)" == "TRUE" ]] && optdepends+=('osgearth-qt4: Globe plugin')
-
- make DESTDIR="$pkgdir" install
-
- cd "$srcdir/$pkgname-$pkgver"
-
- # install desktop files and icons
- install -Dm644 debian/{qgis,qbrowser}.desktop -t "$pkgdir/usr/share/applications/"
- for icon in qgis-icon{,-16x16,-60x60} qbrowser-icon{,-60x60}; do
- local _resolution="${icon##*-}"; [[ "$_resolution" == "icon" ]] && _resolution="512x512"
- install -Dm644 images/icons/$icon.png "$pkgdir/usr/share/icons/hicolor/$_resolution/apps/${icon%%-*}.png"
- done
- for icon in {qgis,qbrowser}_icon; do
- install -Dm644 images/icons/$icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/${icon%%_*}.svg"
- done
-
- # install mime information and icon
- install -Dm644 debian/qgis.xml "$pkgdir/usr/share/mime/packages/qgis.xml"
- install -Dm644 images/icons/qgis-mime-icon.png "$pkgdir/usr/share/icons/hicolor/128x128/mimetypes/qgis-mime.png"
-
- # compile python files, since the cmake option doesn't seem to account for DESTDIR
- python2 -m compileall -q "$pkgdir"
-}