summaryrefslogtreecommitdiff
path: root/pcr/python2-passlib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python2-passlib/PKGBUILD')
-rw-r--r--pcr/python2-passlib/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/pcr/python2-passlib/PKGBUILD b/pcr/python2-passlib/PKGBUILD
new file mode 100644
index 000000000..753677827
--- /dev/null
+++ b/pcr/python2-passlib/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: onny <onny@project-insanity.org>
+# Contributor: onny <onny@project-insanity.org>
+# Maintainer : Parabola GNU /Linux-libre Aurelien Desbrieres <aurelien@cwb.IO>
+
+pkgname=python2-passlib
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="A password hashing library for Python."
+arch=('i686' 'x86_64')
+url=("https://code.google.com/p/passlib/")
+license=('custom')
+depends=('python2')
+source=("https://passlib.googlecode.com/files/passlib-${pkgver}.tar.gz")
+sha512sums=('93c047dc0a06f19a20e5da97db43c5c76e06d69baeac15cc932ef0306ae22dac5c1a3925889a140fd181ab4e00ac513ec829951e15babf5aad89bd2d08dc9907')
+
+build() {
+ cd "$srcdir/passlib-${pkgver}"
+ python2 setup.py build install --root="${pkgdir}" || return 1
+}
+
+# vim:set ts=2 sw=2 et: