summaryrefslogtreecommitdiff
path: root/pcr/python2-glanceclient/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python2-glanceclient/PKGBUILD')
-rw-r--r--pcr/python2-glanceclient/PKGBUILD30
1 files changed, 0 insertions, 30 deletions
diff --git a/pcr/python2-glanceclient/PKGBUILD b/pcr/python2-glanceclient/PKGBUILD
deleted file mode 100644
index 391e98caa..000000000
--- a/pcr/python2-glanceclient/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Contributor: Limao Luo <luolimao+AUR@gmail.com>
-# Maintainer : Parabola GNU / Linux-libre Aurélien DESBRIÈRES <aurelien@hackers.camp>
-
-pkgname=python2-glanceclient
-pkgver=0.12.0
-pkgrel=1
-pkgdesc="OpenStack image service (client libs)"
-arch=(any)
-url=https://launchpad.net/glance
-license=(custom)
-depends=(python2-anyjson python2-crypto python2-eventlet python2-greenlet python2-httplib2
- python2-iso8601 python2-kombu python2-lxml python2-migrate python2-netaddr python2-passlib
- python2-paste python2-paste-deploy python2-routes python2-sendfile python2-sqlalchemy
- python2-webob python2-wsgiref python2-xattr python2-pbr python2-pip)
-makedepends=(python2-setuptools)
-source=(https://pypi.python.org/packages/source/${pkgname:0:1}/${pkgname//2}/${pkgname//2}-$pkgver.tar.gz)
-
-prepare() {
- find ${pkgname//2}-$pkgver -type f -exec sed -ri 's:^#!/usr/bin/(env )?python$:&2:' '{}' \;
-}
-
-build() {
- cd ${pkgname//2}-$pkgver/
- python2 setup.py build
-}
-
-package() {
- cd ${pkgname//2}-$pkgver/
- python2 setup.py install --root="$pkgdir"
-}