summaryrefslogtreecommitdiff
path: root/pcr/python-rosdistro/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python-rosdistro/PKGBUILD')
-rw-r--r--pcr/python-rosdistro/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/pcr/python-rosdistro/PKGBUILD b/pcr/python-rosdistro/PKGBUILD
new file mode 100644
index 000000000..b7d93e7e0
--- /dev/null
+++ b/pcr/python-rosdistro/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+_pkgname=rosdistro
+pkgname=(python-$_pkgname)
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A tool to work with rosdistro files"
+arch=(any)
+url="http://wiki.ros.org/rosdistro"
+license=(BSD3 MIT)
+
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/r/rosdistro/rosdistro-$pkgver.tar.gz")
+sha256sums=('6623545067d5f0098f8f6f460c7613321ab418d04bad3b479cd1cafc1df56195')
+
+_package() {
+ depends=($1)
+ cd "$srcdir"/$_pkgname-$pkgver
+ $1 setup.py install --root="$pkgdir"
+}
+
+for _pkg in "${pkgname[@]}"; do
+ eval "package_$_pkg () { _package ${_pkg%%-*}; }"
+done