summaryrefslogtreecommitdiff
path: root/pcr/heartbeat/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/heartbeat/PKGBUILD')
-rw-r--r--pcr/heartbeat/PKGBUILD202
1 files changed, 0 insertions, 202 deletions
diff --git a/pcr/heartbeat/PKGBUILD b/pcr/heartbeat/PKGBUILD
deleted file mode 100644
index f9ee9254b..000000000
--- a/pcr/heartbeat/PKGBUILD
+++ /dev/null
@@ -1,202 +0,0 @@
-# Maintainer: Márcio Silva <coadde@lavabit.com>
-
-pkgname=heartbeat
-pkgver=3.0.5
-_pkgver=${pkgver::1}_${pkgver:2:1}
-pkgrel=10
-pkgdesc='Daemon that provides cluster infrastructure services to its clients (Linux-HA)'
-arch=(
- i686
- x86_64
- mips64el
-)
-group=linux-ha
-url=http://$group.org/wiki/${pkgname^}
-license=(
- GPL2
- lGPL2.1
-)
-depends=(
- gnutls
- cluster-glue
-)
-optdepends=net-tools
-makedepends=(
- docbook-xsl
- libxslt
- lynx
- net-tools
- openssh
- swig
- valgrind
- w3m
-)
-options=(!libtool)
-provides=(ha-$pkgname)
-conflicts=ha-$pkgname
-replaces=ha-$pkgname
-source=http://hg.$group.org/$pkgname-STABLE_$_pkgver/archive/STABLE-$pkgver.tar.bz2
-sha512sums=e38083b87c56a72eb8925ac42adeabb92618608e92218a63960ec0d0bca264f92a8e9c3ebfb0589cc4538da1a82b268b5cc9ee5a51ed33057c969e694e16b27d
-
-prepare() {
- cd $srcdir/${pkgname^}-3-0-STABLE-$pkgver
-
- mv configure.{in,ac}
-
- sed -i 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|;
- s|AM_INIT_AUTOMAKE(heartbeat, $HAPKGVERSION)|AM_INIT_AUTOMAKE|;
- ' configure.ac
- sed -i "s|AC_INIT(GNUmakefile)|AC_INIT(heartbeat, $pkgver)|;
- " configure.ac
-
- sed -i 's|INCLUDES|AM_CPPFLAGS|;
- ' $(grep -rl INCLUDES | grep Makefile.am)
-
- # fixing path
- sed -i 's|bin/sh|usr/bin/bash|;
- ' $(grep -rl bin/sh)
- sed -i 's| /bin| /usr/bin|;
- ' $(grep -rl ' /bin')
- sed -i 's| /sbin| /usr/bin|;
- ' $(grep -rl ' /sbin')
- sed -i 's|usr/sbin|usr/bin|;
- ' $(grep -rl usr/sbin)
- #sed -i 's|/lib64|/lib|;
- # ' $(grep -rl /lib64)
- #sed -i 's|usr/libexec|usr/lib|;
- # ' $(grep -rl usr/libexec)
- sed -i 's|var/lock|run/lock|;
- ' $(grep -rl var/lock)
- sed -i 's|var/run|run|;
- ' $(grep -rl var/run)
-
- # remove Open Source term
- sed -i 's|Open Source / ||;
- s|open source / ||;
- s|Open Source|Free Software|;
- s|open source|free software|;
- s|Free Software Development Lab|Open Source Development Lab|;
- ' $(grep -ril 'open source')
- #sed -i 's|OpenSource / ||;
- # s|opensource / ||;
- # s|OpenSource|FreeSoftware|;
- # s|opensource|freesoftware|;
- # s|freesoftware.org|opensource.org|;
- # s|http://www.opensource.org/|http://www.gnu.org/philosophy/free-sw.html|;
- # s|http://www.gnu.org/philosophy/free-sw.htmllicenses/osl-|http://opensource.org/licenses/osl-|;
- # s|http://www.gnu.org/philosophy/free-sw.htmlosd|http://opensource.org/osd|;
- # ' $(grep -ril opensource)
-
- # remove Linux term
- sed -i 's|Linux,|GNU/Linux,|;
- s|Linux and|GNU/Linux and|;
- s|Linux distro|GNU/Linux distro|;
- s|Linux distribution|GNU/Linux distribution|;
- s|Linux machine|GNU/Linux machine|;
- s|Linux Only|GNU/Linux Only|;
- s|Linux only|GNU/Linux only|;
- s|Linux operating|GNU/Linux operating|;
- s|Linux OS|GNU/Linux OS|;
- s|Linux platform|GNU/Linux platform|;
- s|Linux software|GNU/Linux software|;
- s|Linux specific|GNU/Linux specific|;
- s|Linux system|GNU/Linux system|;
- s|Linux will|GNU/Linux will|;
- s|# Linux$|# GNU/Linux|;
- s|# Linux.$|# GNU/Linux.|;
- s|* Linux$|* GNU/Linux|;
- s|* Linux.$|* GNU/Linux.|;
- s|// Linux$|// GNU/Linux|;
- s|// Linux.$|// GNU/Linux.|;
- s|, Linux|, GNU/Linux|;
- s|As Linux|As GNU/Linux|;
- s|as Linux|as GNU/Linux|;
- s|And Linux|And GNU/Linux|;
- s|and Linux|and GNU/Linux|;
- s|Be Linux|Be GNU/Linux|;
- s|be Linux|be GNU/Linux|;
- s|Because Linux|Because GNU/Linux|;
- s|because Linux|because GNU/Linux|;
- s|e.g. Linux|e.g. GNU/Linux|;
- s|For Linux|For GNU/Linux|;
- s|for Linux|for GNU/Linux|;
- s|In Linux|In GNU/Linux|;
- s|in Linux|in GNU/Linux|;
- s|Like Linux|Like GNU/Linux|;
- s|like Linux|like GNU/Linux|;
- s|non-Linux|non GNU/Linux|;
- s|Of Linux|Of GNU/Linux|;
- s|of Linux|of GNU/Linux|;
- s|On Linux|On GNU/Linux|;
- s|on Linux|on GNU/Linux|;
- s|OS type: Linux|OS type: GNU/Linux|;
- s|Other Linux|Other GNU/Linux|;
- s|other Linux|other GNU/Linux|;
- s|The Linux|The GNU/Linux|;
- s|the Linux|the GNU/Linux|;
- s|Typically Linux|Typically GNU/Linux|;
- s|typically Linux|typically GNU/Linux|;
- s|To Linux|To GNU/Linux|;
- s|to Linux|to GNU/Linux|;
- s|Under Linux|Under GNU/Linux|;
- s|under Linux|under GNU/Linux|;
- /Linux: "mail" offers "-s"./ s|Linux|GNU/Linux|;
- s|ArchGNU/Linux|ArchLinux|;
- s|e2fsprogs, typically GNU/Linux|e2fsprogs, typically Linux|;
- s|GNU/GNU|GNU|;
- s|GNU/Linux device|Linux device|;
- s|GNU/Linux Director Daemon|Linux Director Daemon|;
- s|GNU/Linux is a registered trademark of Linus Torvalds|Linux is a registered trademark of Linus Torvalds|;
- s|GNU/Linux kernel|Linux kernel|;
- s|GNU/Linux specific kernel|Linux specific kernel|;
- s|GNU/Linux Standard Base|Linux Standard Base|;
- s|GNU/Linux sysfs|Linux sysfs|;
- s|GNU/Linux Virtual Server|Linux Virtual Server|;
- s|GNU/Linux Watchdog|Linux Watchdog|;
- s|GNU/Linux watchdog|Linux watchdog|;
- s|GNU/LinuxHA|LinuxHA|;
- s|GNU/Linux-HA|Linux-HA|;
- s|GNU/LinuxSCSI|LinuxSCSI|;
- s|HA GNU/Linux|HA Linux|;
- s|High-Availability GNU/Linux|High-Availability Linux|;
- s|MkGNU/Linux|MkLinux|;
- s|SEGNU/Linux|SELinux|;
- s|VA GNU/Linux Cluster|VA Linux Cluster|;
- s|ConfigureLinux|ConfigureGNULinux|;
- ' $(grep -rl Linux)
-}
-
-build() {
- cd $srcdir/${pkgname^}-3-0-STABLE-$pkgver
- setarch $CARCH ./bootstrap
- setarch $CARCH ./configure --prefix=/usr\
- --disable-fatal-warnings\
- --disable-static\
- --enable-valgrind\
- --libdir=/usr/lib\
- --localstatedir=/var\
- --sysconfdir=/etc
- setarch $CARCH make
-}
-
-package() {
- cd $srcdir/${pkgname^}-3-0-STABLE-$pkgver
- setarch $CARCH make DESTDIR=$pkgdir install
-
- mv $pkgdir/{var/,}run
- rm $pkgdir/etc/{ha.d/,}rc.d/* && rmdir $pkgdir/etc/{ha.d/,}rc.d
-
- install -d $pkgdir/usr/lib/systemd/system
- echo '[Unit]' > $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo 'Description=Startup script high-availability services' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo 'Requires=network.target remote-fs.target timers.target' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo '' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo '[Service]' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo 'Type=forking' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo 'ExecStart=/usr/lib/heartbeat/heartbeat' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo '' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo '[Install]' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
- echo 'WantedBy=multi-user.target' >> $pkgdir/usr/lib/systemd/system/$pkgname.service
-}
-
-# vim:set ts=2 sw=2 et: