summaryrefslogtreecommitdiff
path: root/pcr/gnome-boxes/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/gnome-boxes/PKGBUILD')
-rw-r--r--pcr/gnome-boxes/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/pcr/gnome-boxes/PKGBUILD b/pcr/gnome-boxes/PKGBUILD
new file mode 100644
index 000000000..0ac23a06b
--- /dev/null
+++ b/pcr/gnome-boxes/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Stefano Facchini <stefano.facchini@gmail.com>
+# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+
+pkgname=gnome-boxes
+pkgver=3.6.1
+pkgrel=2
+pkgdesc="A simple GNOME 3 application to access remote or virtual systems"
+arch=('i686' 'x86_64')
+url="http://live.gnome.org/Boxes"
+license=('LGPL2.1')
+depends=('gtk3' 'clutter-gtk' 'spice-gtk3' 'libvirt-glib' 'tracker'
+ 'gtk-vnc' 'udev' 'libosinfo' 'dconf' 'hicolor-icon-theme'
+ 'desktop-file-utils' 'shared-mime-info')
+optdepends=('qemu-kvm-spice: to create new VMs')
+makedepends=('intltool')
+install=gnome-boxes.install
+source=(http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('fc6ffd0b3886e2da917abdb63470ab9869eef168c002461b9f02ce5aec5383ba')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --libexec=/usr/lib/gnome-boxes
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
+sha256sums=('fc6ffd0b3886e2da917abdb63470ab9869eef168c002461b9f02ce5aec5383ba')