summaryrefslogtreecommitdiff
path: root/pcr/gitflow/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/gitflow/PKGBUILD')
-rw-r--r--pcr/gitflow/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/pcr/gitflow/PKGBUILD b/pcr/gitflow/PKGBUILD
new file mode 100644
index 000000000..b62042262
--- /dev/null
+++ b/pcr/gitflow/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Techlive Zheng <techlivezheng@gmail.com>
+# Contributor: Ernie Brodeur <ebrodeur@ujami.net>
+
+pkgname=gitflow
+pkgver=0.4.1
+pkgrel=3
+pkgdesc='Extend git with the Gitflow branching model.'
+arch=('any')
+url='https://github.com/nvie/gitflow'
+license=('BSD')
+depends=('git' 'shflags')
+source=("https://github.com/nvie/gitflow/tarball/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('adc7a52512052938a9b42ac8bd7d91dd')
+
+prepare() {
+ cd $srcdir/`find . -maxdepth 1 -type d -name nvie\*`
+ sed -i "s:\$GITFLOW_DIR/gitflow-shFlags:/usr/share/lib/shflags/shflags.sh:" git-flow
+}
+
+package() {
+ cd $srcdir/`find . -maxdepth 1 -type d -name nvie\*`
+
+ install -d -m 0755 $pkgdir/usr/lib/git-core
+ install -m 0755 git-flow $pkgdir/usr/lib/git-core
+ install -m 0644 git-flow-feature \
+ git-flow-hotfix \
+ git-flow-release \
+ git-flow-support \
+ git-flow-version \
+ git-flow-init \
+ gitflow-common \
+ $pkgdir/usr/lib/git-core/
+}
+md5sums=('adc7a52512052938a9b42ac8bd7d91dd')