summaryrefslogtreecommitdiff
path: root/pcr/gajim-plugin-omemo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/gajim-plugin-omemo/PKGBUILD')
-rw-r--r--pcr/gajim-plugin-omemo/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/pcr/gajim-plugin-omemo/PKGBUILD b/pcr/gajim-plugin-omemo/PKGBUILD
new file mode 100644
index 000000000..0ef4606fe
--- /dev/null
+++ b/pcr/gajim-plugin-omemo/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: David P. <megver83@parabola.nu>
+# Contributor: Tommaso Sardelli <lacapannadelloziotom AT gmail DOT com>
+
+pkgname=gajim-plugin-omemo
+_pkgname=omemo
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Gajim plugin for OMEMO Multi-End Message and Object Encryption."
+arch=(any)
+url="https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin"
+license=('GPL')
+depends=("gajim" "python2-qrcode" "python2-setuptools" "python2-cryptography" "python2-axolotl" "python2-future")
+provides=('gajim-plugin-omemo')
+conflicts=('gajim-plugin-omemo-git')
+source=("${_pkgname}-${pkgver}.zip::https://ftp.gajim.org/plugins_0.16_zip/${_pkgname}.zip")
+sha512sums=(SKIP)
+
+package() {
+ cd ${srcdir}/${_pkgname}
+
+ # Remove unnecessary files
+ rm -r CHANGELOG COPYING setup.cfg
+
+ # Install the plugin
+ install -d ${pkgdir}/usr/share/gajim/plugins/omemo
+ cp -r * ${pkgdir}/usr/share/gajim/plugins/omemo/
+}
+
+# vim:set ts=2 sw=2 et: