summaryrefslogtreecommitdiff
path: root/pcr/expac-relative/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/expac-relative/PKGBUILD')
-rw-r--r--pcr/expac-relative/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/pcr/expac-relative/PKGBUILD b/pcr/expac-relative/PKGBUILD
index b7a1dcf95..db820175b 100644
--- a/pcr/expac-relative/PKGBUILD
+++ b/pcr/expac-relative/PKGBUILD
@@ -5,8 +5,8 @@
_pkgname=expac
pkgname=expac-relative
-pkgver=3
-pkgrel=1
+pkgver=4
+pkgrel=2.parabola1
pkgdesc="pacman database extraction utility, with dbpath and config options support"
arch=('i686' 'x86_64' 'mips64el')
url="http://github.com/falconindy/expac"
@@ -16,15 +16,18 @@ provides=($_pkgname)
depends=('pacman')
makedepends=('perl')
source=("http://code.falconindy.com/archive/$_pkgname/$_pkgname-$pkgver.tar.gz"{,.sig}
- 'add-options-dbpath-and-config.patch')
-md5sums=('2f53f9663b69948a4a8bb03c1aa435a5'
+ '0001-fix-target-processing.patch'
+ '0002-conf-always-trim-the-key-name.patch')
+md5sums=('5104ad808155e8d2d381d9282caf7bae'
'SKIP'
- '30539a5f7d1acbebb393535ae8ecf570')
+ '80433a259a4f5996520f42217b1896b8'
+ '879749918e1a4abef4c51e9f870c99e0')
prepare() {
cd "$_pkgname-$pkgver"
- patch -Np1 -i "$srcdir/add-options-dbpath-and-config.patch"
+ patch -Np1 < "$srcdir/0001-fix-target-processing.patch"
+ patch -Np1 < "$srcdir/0002-conf-always-trim-the-key-name.patch"
sed '/\*\//q' expac.c >LICENSE
}