summaryrefslogtreecommitdiff
path: root/pcr/debootstrap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/debootstrap/PKGBUILD')
-rw-r--r--pcr/debootstrap/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/pcr/debootstrap/PKGBUILD b/pcr/debootstrap/PKGBUILD
new file mode 100644
index 000000000..04ffd6fd4
--- /dev/null
+++ b/pcr/debootstrap/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jan Dolinar <dolik.rce@gmail.com>
+# Contributor: Abakus <java5 at arcor dot de>
+pkgname=debootstrap
+pkgver=1.0.42
+pkgrel=2
+pkgdesc="A tool used to create a Debian base system from scratch, without requiring the availability of dpkg or apt"
+arch=('any')
+license=('GPL')
+url="http://packages.qa.debian.org/d/debootstrap.html"
+depends=('bash' 'wget')
+optdepends=( 'debian-archive-keyring: checking Debian release signatures'
+ 'gnupg1: checking Debian release signatures' )
+source=("http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}_all.deb")
+install="debootstrap.install"
+md5sums=('9bf9583ae731210d582d65aa276d48aa')
+
+build(){
+ tar -xzf "${srcdir}/data.tar.gz" -C "${pkgdir}/"
+ # doesn't work with gpg 2.x, patch to point to gpgv1
+ sed 's/gpgv/gpgv1/g;' -i "${pkgdir}/usr/sbin/debootstrap" "${pkgdir}/usr/share/debootstrap/functions"
+}