summaryrefslogtreecommitdiff
path: root/pcr/corosync/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/corosync/PKGBUILD')
-rw-r--r--pcr/corosync/PKGBUILD91
1 files changed, 58 insertions, 33 deletions
diff --git a/pcr/corosync/PKGBUILD b/pcr/corosync/PKGBUILD
index e7c019a66..0214f521e 100644
--- a/pcr/corosync/PKGBUILD
+++ b/pcr/corosync/PKGBUILD
@@ -1,38 +1,63 @@
-# Maintainer: Eric Renfro <erenfro@gmail.com>
+# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
pkgname=corosync
-pkgver=2.1.0
-pkgrel=4
-pkgdesc="Cluster engine for nodal communication systems with additional features for implementing high availability within applications."
-arch=('i686' 'x86_64')
-url="http://www.corosync.org/"
-license=('BSD')
-makedepends=('nss' 'libstatgrab' 'net-snmp' 'libqb')
-depends=('nss' 'libstatgrab' 'net-snmp' 'libqb')
-provides=('corosync=2.1.0')
-conflicts=('corosync1')
-#source=(ftp://ftp:downloads@ftp.corosync.org/downloads/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz)
-source=("https://github.com/downloads/corosync/corosync/corosync-${pkgver}.tar.gz"
- "corosync.init"
- "corosync.service")
-md5sums=('dc5152e6dfdb4638ab544e587884483a'
- 'fdc3b648f020e165eaa7c3283ce5b9ac'
- 'abc267226faafc7dc8246634277705ea')
-
+_pkgflag=lts
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='Cluster engine for nodal communication systems with additional features for implementing high availability within applications'
+arch=(
+ i686
+ x86_64
+ mips64el
+)
+url=http://www.$pkgname.org
+license=BSD
+depends=(
+ libqb
+ libstatgrab
+ net-snmp
+ nss
+)
+makedepends=doxygen
+conflicts=$pkgname-$_pkgflag
+options=(!libtool)
+source=http://$pkgname.org/download/$pkgname-$pkgver.tar.gz
+sha512sums=cd2ff5182f0d4827a10d50a211aa073e3d544bf7b98f9b0c834243c0d2cd5446d7950021cb1a21fc16f4951c8b2acf4b75c0b0c72d815b7d67dcba71623d2e51
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+}
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --enable-systemd \
- --enable-monitoring \
- --enable-snmp \
- --enable-dbus \
- --with-systemddir=/usr/lib/systemd/system
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- ## Updated and fixed up systemd service unit and associated start/stop script:
- cp ${srcdir}/corosync.service ${pkgdir}/usr/lib/systemd/system/corosync.service || return 1
- cp ${srcdir}/corosync.init ${pkgdir}/usr/share/corosync/corosync || return 1
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr\
+ --datarootdir=/usr/share\
+ --disable-coverage\
+ --disable-fatal-warnings\
+ --disable-rdma\
+ --disable-static\
+ --enable-augeas\
+ --enable-dbus\
+ --enable-monitoring\
+ --enable-qdevices\
+ --enable-secure-build\
+ --enable-shared\
+ --enable-snmp\
+ --enable-systemd\
+ --enable-testagents\
+ --enable-watchdog\
+ --enable-xmlconf\
+ --libdir=/usr/lib\
+ --localstatedir=/var\
+ --sysconfdir=/etc\
+ --with-initddir=/etc/rc.d\
+ --with-systemddir=/usr/lib/systemd/system
+ setarch $CARCH make
+}
+
+package () {
+ cd $srcdir/$pkgname-$pkgver
+ setarch $CARCH make DESTDIR=$pkgdir install
}
+# vim:set ts=2 sw=2 et: