summaryrefslogtreecommitdiff
path: root/pcr/belle-sip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/belle-sip/PKGBUILD')
-rw-r--r--pcr/belle-sip/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/pcr/belle-sip/PKGBUILD b/pcr/belle-sip/PKGBUILD
new file mode 100644
index 000000000..3d5d1768a
--- /dev/null
+++ b/pcr/belle-sip/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: David P. <megver83@parabola.nu>
+
+pkgname=belle-sip
+pkgver=4.4.0
+pkgrel=1
+pkgdesc='A modern library implementing SIP (RFC3261) transport, transaction and dialog layers'
+arch=(x86_64 i686)
+url='http://linphone.org/'
+license=(GPL)
+depends=(avahi bctoolbox)
+makedepends=(cmake)
+options=('!emptydirs')
+source=("https://gitlab.linphone.org/BC/public/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('4f9218b0bbf55c2f68d70a0e83779e591ef9fe97f1caf7550768ea192ee34cee')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_STATIC=NO \
+ -DENABLE_MDNS=YES \
+ -DENABLE_STRICT=YES \
+ -DENABLE_TESTS=NO .
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}