summaryrefslogtreecommitdiff
path: root/pcr-testing/xen/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr-testing/xen/PKGBUILD')
-rw-r--r--pcr-testing/xen/PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/pcr-testing/xen/PKGBUILD b/pcr-testing/xen/PKGBUILD
index 89d5ea346..802639c96 100644
--- a/pcr-testing/xen/PKGBUILD
+++ b/pcr-testing/xen/PKGBUILD
@@ -1,4 +1,4 @@
-# current version adapted from https://gitlab.com/johnth/aur-xen/blob/717dc1c8e32c3c615652f2b40838d1cb12441073/PKGBUILD
+# current version adapted from https://gitlab.com/johnth/aur-xen/blob/ea6a7a5938eb8bb4fbcd5de11220b2a7bbe12121/PKGBUILD
# Maintainer (AUR): John Thomson <aur.xen at j0aur.mm.st>
# Contributor (Arch): David Sutton <kantras - gmail.com>
@@ -36,7 +36,7 @@ pkgname=(xen{,-docs,-syms})
_pkgname=xen
pkgver=4.9.0
_pkgver=${pkgver/rc/-rc}
-pkgrel=1.parabola1
+pkgrel=1.parabola2
pkgdesc="Virtual Machine Hypervisor & Tools (Parabola rebranded)"
arch=(x86_64 armv7h)
depends=(
@@ -146,6 +146,7 @@ source=(
patch-gcc7-vtpm-implicit-fallthrough.patch
patch-gcc7-vtpmmgr-make-inline-static.patch
patch-gcc7-minios-udivmod.patch
+ patch-gcc7-rombios.patch::'https://xenbits.xen.org/gitweb/?p=xen.git;a=commitdiff_plain;h=672949d6c61d9cba01c5b414eed9d522082f04d3'
## Files
xen.install
@@ -214,12 +215,12 @@ sha256sums=(
'0ce9de822712e2b538dc144ba23b584970ac73b327277917b4afaa321c5b4b0c'
'5727d42575dfac1870d235fab23b8a230857cfdf44372bc1d98bb6384b752367'
'b6fa5bff89242719b20747d7eb197d0aeb59f8a89e841137f0b0cab17de20686'
+ '70b41197cde89d71e37d0c0d2af7087f4ec0a85db3f3e01f22cd2f91bf68b3c8'
#pkgbuild files
'330bcc5ab22e982d37495b57176d306353c220fec7c2b6c4a78a9133382a623e'
'9b2e6880d6345d1029317d7d65c85e07039b795c988b6852159d2ad673b13930'
'95f09bccc104d98c14559000823cb50f0d076f6a65b9f3b4e7725762b84ab5c7'
- '50a9b7fd19e8beb1dea09755f07318f36be0b7ec53d3c9e74f3266a63e682c0c'
'40e0760810a49f925f2ae9f986940b40eba477dc6d3e83a78baaae096513b3cf'
## XSA patches
@@ -284,6 +285,7 @@ prepare() {
# Compile Patches
echo 'Compile patches'
+ patch -Np1 -i "$srcdir/patch-gcc7-rombios.patch"
# Build EFI binary with mingw
if [[ "$_binutils_efi" != true ]]; then