summaryrefslogtreecommitdiff
path: root/pcr-testing/python-lazr-delegates/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr-testing/python-lazr-delegates/PKGBUILD')
-rw-r--r--pcr-testing/python-lazr-delegates/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/pcr-testing/python-lazr-delegates/PKGBUILD b/pcr-testing/python-lazr-delegates/PKGBUILD
new file mode 100644
index 000000000..73f68d29a
--- /dev/null
+++ b/pcr-testing/python-lazr-delegates/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: bill-auger <bill-auger@programmer.net>
+# Maintainer (AUR): Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+
+pkgname=('python-lazr-delegates' 'python2-lazr-delegates')
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="Easily write objects that delegate behavior"
+arch=(any)
+url=https://launchpad.net/lazr.delegates
+license=('LGPL')
+options=(!emptydirs)
+
+makedepends=('python-setuptools' 'python2-setuptools')
+
+_upstream_name='lazr.delegates'
+_release=${_upstream_name}-${pkgver}
+source=(https://pypi.python.org/packages/source/${_upstream_name:0:1}/${_upstream_name}/${_release}.tar.gz)
+sha256sums=('51c80d5ac2c1f8f4a8c75fa271646529c8a6393a0b088dab50fb62138d092ee9')
+
+
+package_python-lazr-delegates()
+{
+ depends=('python' 'python-setuptools' 'python-zope-interface' 'python-nose')
+
+ cd "${srcdir}/${_release}"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-lazr-delegates() {
+ depends=('python2' 'python2-setuptools' 'python2-zope-interface' 'python2-nose')
+
+ cd "${srcdir}/${_release}"
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}