summaryrefslogtreecommitdiff
path: root/nonsystemd/parabola-base/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/parabola-base/PKGBUILD')
-rw-r--r--nonsystemd/parabola-base/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/nonsystemd/parabola-base/PKGBUILD b/nonsystemd/parabola-base/PKGBUILD
new file mode 100644
index 000000000..b1822a0eb
--- /dev/null
+++ b/nonsystemd/parabola-base/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: bill-auger <bill-auger@programmer.net>
+
+# this is the canonical definition of the standard Parabola non-systemd CLI system
+# as installed onto the non-systemd CLI LiveISOs, and installed by the installers
+# users may also use this meta-package during the manual install process
+# to replicate the non-systemd CLI live system
+
+
+pkgname=parabola-base
+pkgver=2
+pkgrel=1
+pkgdesc="Extended package-set to define the standard Parabola GNU/Linux-libre non-systemd CLI system"
+url=https://www.parabola.nu
+arch=('any')
+license=('GPL')
+
+
+# (deprecated 'base-openrc' group) - ('nonsystemd/base' meta-package) + posix
+depends=(cryptsetup dhcpcd elogind inetutils jfsutils linux-libre logrotate lvm2
+ mdadm openresolv posix reiserfsprogs sysfsutils usbutils vi xfsprogs) # TODO: your-system-sanity
+
+# supplemental package-set for the non-systemd CLI LiveISOs
+depends+=(bash-completion elinks haveged hdparm mc nano networkmanager ntp
+ openssh openvpn p7zip rsync screen sudo unarchiver unzip w3m zip)
+
+# TODO: these are in the deprecated 'base-openrc' group
+# (most important, installed in ths group, is 'udev-init-scripts')
+# many of these will eventually be moved from [pcr] into the corresponding
+# main program packages [nonsystemd] (without the *-openrc suffix)
+# once that happens, these can be merged into the base packages array above
+# https://labs.parabola.nu/issues/2549
+depends+=(cronie-openrc cryptsetup-openrc dhcpcd-openrc glibc-openrc
+ inetutils-openrc lvm2-openrc mdadm-openrc netifrc nfs-utils-openrc
+ quota-tools-openrc rpcbind-openrc syslog-ng-openrc udev-init-scripts)
+
+# TODO: analogous *-openrc sub-set, corresponding to the supplemental LiveISOs package set
+# these can eventually be merged into the supplemental packages array above
+# https://labs.parabola.nu/issues/2549
+depends+=(gpm-openrc haveged-openrc hdparm-openrc ntp-openrc openssh-openrc
+ openvpn-openrc rsync-openrc wpa_supplicant-openrc)