summaryrefslogtreecommitdiff
path: root/nonsystemd/filesystem/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/filesystem/PKGBUILD')
-rw-r--r--nonsystemd/filesystem/PKGBUILD70
1 files changed, 45 insertions, 25 deletions
diff --git a/nonsystemd/filesystem/PKGBUILD b/nonsystemd/filesystem/PKGBUILD
index 9d0b8c401..de0b8f2ca 100644
--- a/nonsystemd/filesystem/PKGBUILD
+++ b/nonsystemd/filesystem/PKGBUILD
@@ -1,9 +1,18 @@
# Maintainer: David P. <megver83@parabola.nu>
-# Maintainer (Arch): Sébastien Luttringer
-# Contributor (Arch): Tom Gundersen <teg@jklm.no>
+# Maintainer (arch): Sébastien Luttringer
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
+
+# parabola changes and rationale:
+# - parabola branding (os-release,motd,icon,logo)
+# - systemd-specific 'env-generator' is not used for nonsystemd
+
pkgname=filesystem
-pkgver=2021.01.19
+pkgver=2021.12.07
pkgrel=1
pkgrel+=.parabola1
pkgrel+=.nonsystemd1
@@ -14,26 +23,30 @@ license=('GPL')
url='https://www.parabola.nu'
depends=('iana-etc')
backup=('etc/crypttab' 'etc/fstab' 'etc/group' 'etc/gshadow' 'etc/host.conf'
- 'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/motd' 'etc/nsswitch.conf'
+ 'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/nsswitch.conf'
'etc/passwd' 'etc/profile' 'etc/resolv.conf' 'etc/securetty'
'etc/shadow' 'etc/shells')
-source=('crypttab' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts' # 'env-generator
- 'issue' 'ld.so.conf' 'locale.sh' 'motd' 'nsswitch.conf' 'os-release'
+backup+=('etc/motd')
+source=('crypttab' 'env-generator' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts'
+ 'issue' 'ld.so.conf' 'locale.sh' 'nsswitch.conf' 'os-release'
'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells' 'sysctl'
- 'sysusers' 'tmpfiles' 'parabola.svg' 'parabola.png'
- 'parabola-logo.svg' 'parabola-logo.png')
+ 'sysusers' 'tmpfiles' 'archlinux-logo.svg' 'archlinux-logo.png'
+ 'archlinux-logo-text.svg' 'archlinux-logo-text-dark.svg')
+source=( ${source[*]/env-generator/} )
+source=( ${source[*]//archlinux-logo/parabola-logo} )
+source+=('motd')
sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
+ # (env-generator is not used for nonsystemd)
'e54626e74ed8fee4173b62a545ab1c3a3a069e4217a0ee8fc398d9933e9c1696'
'244f0718ee2a9d6862ae59d6c18c1dd1568651eada91a704574fa527fbac2b3a'
'90d879374f77bac47f132164c1e7fc4892e994ff1d1ac376efa0c1c26ea37273'
'4d7b647169063dfedbff5e1e22cee77bd1a4183dbcfd5e802e68939da4bbf733'
'd9cd8a77d9e0aa5e90d7f4ed74c8745c17b525e720e28e4c44364150003c35f9'
- '8b8f24af3454e87b4e316b4978d0de7958a98cc44606aa801d9696d2c21f4385'
+ '8b8f24af3454e87b4e316b4978d0de7958a98cc44606aa801d9696d2c21f4385' # issue
'dad04a370e488aa85fb0a813a5c83cf6fd981ce01883fc59685447b092de84b5'
'8ca2d8eef6fb5143c9ef7e9174ccfef59ac7ad2deee243574cd10c763156cc10'
- 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
- 'aa4dc5b2374fb32863e3bc1ce20a2de2d34fe4eed1cd63c599bc82fab21463cc'
- '8426638643316faebeee3af660bb8075e4b5dba494c84078c620384d4c6db4c3'
+ 'aa4dc5b2374fb32863e3bc1ce20a2de2d34fe4eed1cd63c599bc82fab21463cc' # nsswitch.conf
+ 'af2eee47719566740b750f0806e897a8439656df4a7476bb6e71465fd075b45d' # os-release
'5e06477834f51abf42ea4e8dc199632afc6afbfd8c44354685a271e9a48d2c0a'
'5e4088ad8d0853d390fa303f6be8c3f69c33834200cba9e90f7849f1993ca8d0'
'5557d8e601b17a80d1ea7de78a9869be69637cb6a02fbfe334e22fdf64e61d4c'
@@ -41,12 +54,21 @@ sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
'6e13705ac4d6f69cdba118c6b70c722346fd3c45224133e6bbfe28aca719563c'
'c390b31fffc4a2b5d78ae8c89f5317aadef1f71baac09cfb467b675db1406d61'
'89e43a0b7028f52d5c8e7fb961d962c4b4f4e9595880a6157274ddb2c7c0b6b4'
- '04dd4cbe5078f5181176ade3a82f333e3f48091b118360d69cc45a3526503818'
- '618ac097441c1f2daffc9967e5c3cd18ea8866f776db62d04bf401c53907b1c9'
- 'cb8ece3772744ef162d0ff6018e6a7051889c2aba1bf6439ba9e74a64ac46927'
- '826c61cb40bb0b31e2071b21e04ad7f8c6aabe2817e681246569ae9dff81cd9b'
- 'cb8ece3772744ef162d0ff6018e6a7051889c2aba1bf6439ba9e74a64ac46927'
- '826c61cb40bb0b31e2071b21e04ad7f8c6aabe2817e681246569ae9dff81cd9b')
+ '04dd4cbe5078f5181176ade3a82f333e3f48091b118360d69cc45a3526503818' # sysusers
+ 'f17efd1c6480c5db1fdab4a0e3cfcd4baa44a3e1ae1210aebeb40f8d5c82f742'
+ 'd5f0a4f75761afd5ebbc6970ac9aba5be3c28bb660adf7118353a0e018911e68' # parabola-logo.svg
+ 'c6486f4c9456fa62a75727adfcc8f2403a1a9fac29386f942c0678c109cc72e8' # parabola-logo.png
+ '09838fea00c5ceff6e7ed28bb1b6d62feb1e2471df9fe5a4328071ecb9e837f3' # parabola-logo-text.svg
+ 'bc9be3442fab17ac6990814db4c0cc76c2ac6112c70a6c103530f607aa54c11e') # parabola-logo-text-dark.svg
+sha256sums+=('0018e0387155ee65472f71f0003fcbcb863355d12442150922e7156da12cabad') # motd
+
+
+prepare() {
+ # inject OS variant information into os-release
+ local init='OpenRC'
+ sed -i "s|@VARIANT@|${CARCH} ${init} Edition|" "${srcdir}"/os-release
+ sed -i "s|@VARIANT_ID@|${CARCH}-${init,,}|" "${srcdir}"/os-release
+}
package() {
cd "$pkgdir"
@@ -65,7 +87,7 @@ package() {
# setup /etc and /usr/share/factory/etc
install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
- for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf \
+ for f in fstab group host.conf hosts issue ld.so.conf nsswitch.conf \
passwd resolv.conf securetty shells profile; do
install -m644 "$srcdir"/$f etc/
install -m644 "$srcdir"/$f usr/share/factory/etc/
@@ -75,8 +97,9 @@ package() {
install -m600 "$srcdir"/$f etc/
install -m600 "$srcdir"/$f usr/share/factory/etc/
done
+ touch etc/arch-release
touch etc/parabola-release
- ln -sv parabola-release etc/arch-release
+ install -m644 "$srcdir"/motd etc/
install -m644 "$srcdir"/locale.sh etc/profile.d/locale.sh
install -Dm644 "$srcdir"/os-release usr/lib/os-release
@@ -102,14 +125,11 @@ package() {
# add lib symlinks
ln -s usr/lib lib
+ [[ $CARCH = 'ppc64le' ]] || \
[[ $CARCH = 'x86_64' ]] && {
ln -s usr/lib lib64
ln -s lib usr/lib64
}
- [[ $CARCH = 'powerpc64le' ]] && {
- ln -s usr/lib lib64
- ln -s lib usr/lib64
- }
# add bin symlinks
ln -s usr/bin bin
@@ -135,5 +155,5 @@ package() {
# (env-generator is not used for nonsystemd)
# add logo
- install -D -m644 "$srcdir"/parabola{,-logo}.{svg,png} usr/share/pixmaps
+ install -D -m644 "$srcdir"/parabola-logo{.png,.svg,-text.svg,-text-dark.svg} usr/share/pixmaps
}