summaryrefslogtreecommitdiff
path: root/nonprism/webkit2gtk/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/webkit2gtk/PKGBUILD')
-rw-r--r--nonprism/webkit2gtk/PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/nonprism/webkit2gtk/PKGBUILD b/nonprism/webkit2gtk/PKGBUILD
index 765fb4e4c..00bed4e58 100644
--- a/nonprism/webkit2gtk/PKGBUILD
+++ b/nonprism/webkit2gtk/PKGBUILD
@@ -1,11 +1,11 @@
# $Id: PKGBUILD 289009 2017-02-15 15:43:20Z jgc $
# Contributor (Arch): Eric Bélanger <eric@archlinux.org>
-# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor: André Silva <emulatorman@riseup.net>
# Contributor: Luke R. <g4jc@openmailbox.org>
pkgname=webkit2gtk
-pkgver=2.14.5
-pkgrel=1.nonprism1
+pkgver=2.17.2
+pkgrel=2.nonprism1
pkgdesc="GTK+ Web content engine library, without geoclue2 support"
arch=(i686 x86_64)
url="https://webkitgtk.org/"
@@ -18,8 +18,9 @@ optdepends=('gtk2: Netscape plugin support'
'gst-plugins-good: media decoding'
'gst-libav: nonfree media decoding')
options=(!emptydirs)
-source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc})
-sha256sums=('3ca8f1c33a9b43d6c753dcac1c0788656930e06382b10fdf5c2805ea8f96369f'
+source=("https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz" #{,.sig}
+ 'icu59.patch')
+sha256sums=('7ad9d11fe247100f476fc70bc9e425306cf56aa97b399dce52964493a9c666e0'
'SKIP')
validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3')
@@ -29,7 +30,8 @@ prepare() {
cd webkitgtk-$pkgver
sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
rm -r Source/ThirdParty/gtest/
- rm -r Source/ThirdParty/qunit/
+ #rm -r Source/ThirdParty/qunit/
+ patch -Np1 -i ../icu59.patch
}
build() {
@@ -37,7 +39,7 @@ build() {
cmake -DPORT=GTK -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=/usr/lib -DLIBEXEC_INSTALL_DIR=/usr/lib/webkit2gtk-4.0 \
- -DUSE_GEOCLUE2=OFF -DENABLE_GEOLOCATION=OFF \
+ -DUSE_GEOCLUE2=OFF -DENABLE_GEOLOCATION=OFF \
-DENABLE_GTKDOC=ON -DPYTHON_EXECUTABLE=/usr/bin/python2 ../webkitgtk-$pkgver
if [[ "$CARCH" =~ ^arm*|^aarch64$ ]]; then
# strip -O3 from cmake generated makefiles