summaryrefslogtreecommitdiff
path: root/nonprism/jitsi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/jitsi/PKGBUILD')
-rw-r--r--nonprism/jitsi/PKGBUILD43
1 files changed, 21 insertions, 22 deletions
diff --git a/nonprism/jitsi/PKGBUILD b/nonprism/jitsi/PKGBUILD
index 0696c0a8a..e8e082dde 100644
--- a/nonprism/jitsi/PKGBUILD
+++ b/nonprism/jitsi/PKGBUILD
@@ -1,39 +1,36 @@
-# Contributor (Arch): Xavier Devlamynck <magicrhesus@ouranos.be>
-# Contributor (Arch): Keshav P R, atommix aka Aleks Lifey, Xavion, Ananda Samaddar, Dan Serban, Xyne
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Maintainer (Arch): Xavier Devlamynck <magicrhesus@ouranos.be>
+# Contributors (Arch): Keshav P R, atommix aka Aleks Lifey, Xavion, Ananda Samaddar, Dan Serban, Xyne
+# Contributor: Andreas Grapentin <andreas@grapentin.org>
+# Contributor: André Silva <emulatorman@hyperbola.info>
# Contributor: Márcio Silva <coadde@hyperbola.info>
+# parabola changes and rationale:
+# - removing support for possibly unsafe protocols
+# - fix usage of "open source" and "linux" terms
+
pkgname=jitsi
-pkgver=2.8.5426
-pkgrel=1.nonprism1
+pkgver=2.10.5550
+pkgrel=4.nonprism1
pkgdesc="An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator), without support for unsafe and dangerous for privacy protocols"
arch=('i686' 'x86_64')
url="http://jitsi.org"
-license=('LGPL')
-replaces=(${pkgname}-nonprism)
-conflicts=(${pkgname}-nonprism)
+license=('Apache')
depends=('java-runtime')
-makedepends=('apache-ant' 'java-environment')
+makedepends=('apache-ant' 'java-environment-common')
options=(!strip !emptydirs zipman !libtool docs)
-source=("http://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
+source=("https://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
jitsi.desktop
jitsi.sh
- drop-open-term-on-index-jn-html.patch
- nonprism.patch)
-sha256sums=('e649867e186cf195c4b1bb159d7ffe0a38c4dc60659e5c55f9a74461a309f36c'
+ nonprism.patch)
+sha256sums=('cdfc6f038d1b877c42d26dba1864ac7c6b554dd55c18767a29f2db3618647287'
'61e3bec3470790fa067f87d978016ec4452a6fd3dfba2c9afa5245b58d3cb19d'
- '529722efc3bae6cb8923680363a4d778ccf78db9caf20bee90a110d34181d9f5'
- 'a862465431e9d272e00bb9aafe56edec0d5c4f3718062add53972685adb90631'
- 'bb3a3473fb70b6392ec3c8b400f81c18e1895b9186817401d9fca69e251223aa')
+ 'c47bfa98fe36378f2e7b947cd248582f5a90c1b169d53d158badb00439fdc6c7'
+ '437c550c93688efb7f5bec5564093193a663257f9f455fcd5551106db23b2ed3')
prepare() {
cd $srcdir/$pkgname
- # append the build revision to the jitsi version
- sed -i "s|0.build.by.SVN|build.$pkgver|" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
-
# remove Open Source term
- patch -Np0 -i ../drop-open-term-on-index-jn-html.patch
sed -i 's|Open Source / ||;
s|open source / ||;
s|Open Source|Free Software|;
@@ -73,13 +70,15 @@ prepare() {
}
build() {
- cd $srcdir/$pkgname
+ cd "${srcdir}/${pkgname}"
+ # append the build revision to the jitsi version
+ sed -i "s/0\.build\.by\.SVN/build.${pkgver}/" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
. /etc/profile.d/apache-ant.sh
ant rebuild
}
package() {
- cd $srcdir/$pkgname
+ cd "${srcdir}/${pkgname}"
find lib/ lib/bundle/ -maxdepth 1 -type f -exec install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/"{} \;
# find lib/os-specific/linux/ -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/lib/"{} \;
shopt -sq extglob