summaryrefslogtreecommitdiff
path: root/nonprism/jitsi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/jitsi/PKGBUILD')
-rw-r--r--nonprism/jitsi/PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/nonprism/jitsi/PKGBUILD b/nonprism/jitsi/PKGBUILD
index e8e082dde..6e9bb9c1a 100644
--- a/nonprism/jitsi/PKGBUILD
+++ b/nonprism/jitsi/PKGBUILD
@@ -10,13 +10,14 @@
pkgname=jitsi
pkgver=2.10.5550
-pkgrel=4.nonprism1
+pkgrel=7
+pkgrel+=.nonprism1
pkgdesc="An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator), without support for unsafe and dangerous for privacy protocols"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://jitsi.org"
license=('Apache')
-depends=('java-runtime')
-makedepends=('apache-ant' 'java-environment-common')
+depends=('java-runtime=8')
+makedepends=('ant' 'java-environment=8')
options=(!strip !emptydirs zipman !libtool docs)
source=("https://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
jitsi.desktop
@@ -24,7 +25,7 @@ source=("https://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
nonprism.patch)
sha256sums=('cdfc6f038d1b877c42d26dba1864ac7c6b554dd55c18767a29f2db3618647287'
'61e3bec3470790fa067f87d978016ec4452a6fd3dfba2c9afa5245b58d3cb19d'
- 'c47bfa98fe36378f2e7b947cd248582f5a90c1b169d53d158badb00439fdc6c7'
+ 'b22ae316fece079ce7f56060f79722d74867562ec12b9a5279d144eb359587c9'
'437c550c93688efb7f5bec5564093193a663257f9f455fcd5551106db23b2ed3')
prepare() {
@@ -73,7 +74,6 @@ build() {
cd "${srcdir}/${pkgname}"
# append the build revision to the jitsi version
sed -i "s/0\.build\.by\.SVN/build.${pkgver}/" src/net/java/sip/communicator/impl/version/NightlyBuildID.java
- . /etc/profile.d/apache-ant.sh
ant rebuild
}