summaryrefslogtreecommitdiff
path: root/nonprism/claws-mail/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/claws-mail/PKGBUILD')
-rw-r--r--nonprism/claws-mail/PKGBUILD42
1 files changed, 30 insertions, 12 deletions
diff --git a/nonprism/claws-mail/PKGBUILD b/nonprism/claws-mail/PKGBUILD
index 0a6a3fd7a..5e237b8f5 100644
--- a/nonprism/claws-mail/PKGBUILD
+++ b/nonprism/claws-mail/PKGBUILD
@@ -5,20 +5,21 @@
# parabola changes and rationale:
-# - removed libgdata support (--help)
+# - removed 'libgdata' support (--help) and optdepends
+# - FIXME: added 'webkit2gtk' dep; but the arch PKGBUILD does not require it
pkgname=claws-mail
-pkgver=3.17.8
-pkgrel=1
-pkgrel+=.nonprism1
-pkgdesc="A GTK+ based e-mail client."
-pkgdesc="${pkgdesc//./}, without libgdata support"
+pkgver=4.0.0
+pkgrel=3
+pkgrel+=.nonprism2
+pkgdesc="A GTK+ based e-mail client"
+pkgdesc+=", without libgdata support"
arch=('x86_64')
arch+=('armv7h' 'i686')
license=('GPL3')
url="https://www.claws-mail.org"
-depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
+depends=('gtk3' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
'libetpan' 'compface' 'libsm' 'dbus-glib')
makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
# dependencies for plugins
@@ -27,6 +28,7 @@ makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
# deps to build the docs
'docbook-utils' 'texlive-formatsextra')
makedepends=(${makedepends[@]/libgdata/})
+makedepends+=('webkit2gtk') # FIXME:
optdepends=('python: needed for some tools'
'perl: needed for some tools and perl plugin'
'spamassassin: adds support for spamfiltering'
@@ -34,23 +36,37 @@ optdepends=('python: needed for some tools'
'libnotify: for notification plugin'
'libcanberra: for notification plugin'
'dbus: for notification plugin'
- 'libxml2: for gtkhtml2_viewer and rssyl plugins'
- 'curl: for gtkhtml2_viewer, vcalendar, rssyl and spamreport plugins'
+ 'libxml2: for rssyl plugins'
+ 'curl: for vcalendar, rssyl and spamreport plugins'
'libarchive: for archive plugin and various other plugins'
'libytnef: for tnef_parse plugin'
'poppler-glib: for pdf viewer plugin'
'ghostscript: for pdf viewer plugin'
'libical: for vcalendar plugin'
- 'dillo: for html viewer plugin'
+ 'dillo: for dillo html viewer plugin'
+ 'webkit2gtk: for fancy webkit html viewer plugin'
'gumbo-parser: for litehtml plugin')
provides=('claws')
+install=$pkgname.install
source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
+ 0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
+ 0002_Fancy_crashes_when_opening_an_email.diff
bash_completion)
-sha256sums=('cdb7b2814995d6f4a9c3b1f0bc1467ed5c3cf2a5e0da1730aaa25a8accafddaf'
+sha256sums=('4af2bd26a5d91eacb2a9c09f67a6a46c2222b40817c1f525dc050bdc7b0ee475'
'SKIP'
+ 'ffd5dfe8929a86667218512095a794263a2ae56fae4add83d3ad987f94e7f786'
+ 'f56256a9535958063b966ab52abdf787422ff71ed2a5c41b3d9fea8716defe85'
'3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
+
+prepare() {
+ cd "${pkgname}"-${pkgver}
+ # upstream fixes
+ patch -Np1 -i ../0001_move_OAuth2_to_last_place_in_auto_auth_selection.diff
+ patch -Np1 -i ../0002_Fancy_crashes_when_opening_an_email.diff
+}
+
build() {
cd "${pkgname}"-${pkgver}
./configure --prefix=/usr --disable-static \
@@ -61,7 +77,9 @@ build() {
--disable-gdata-plugin \
--enable-pgpmime-plugin \
--enable-spamassassin-plugin \
- --enable-bogofilter-plugin
+ --enable-bogofilter-plugin \
+ --enable-fancy-plugin \
+ --enable-manual
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}