summaryrefslogtreecommitdiff
path: root/nonprism/claws-mail/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/claws-mail/PKGBUILD')
-rw-r--r--nonprism/claws-mail/PKGBUILD81
1 files changed, 37 insertions, 44 deletions
diff --git a/nonprism/claws-mail/PKGBUILD b/nonprism/claws-mail/PKGBUILD
index 9017be37e..0a6a3fd7a 100644
--- a/nonprism/claws-mail/PKGBUILD
+++ b/nonprism/claws-mail/PKGBUILD
@@ -1,27 +1,33 @@
-# $Id$
-# Maintainer (Arch): Andreas Radke <andyrtr@archlinux.org>
+# Maintainer (arch): Andreas Radke <andyrtr@archlinux.org>
# Contributor: Andreas Grapentin <andreas@grapentin.org>
# Contributor: Márcio Silva <coadde@hyperbola.info>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
# parabola changes and rationale:
-# - removed libgdata support
+# - removed libgdata support (--help)
+
pkgname=claws-mail
-pkgver=3.16.0
-pkgrel=3.nonprism1
-pkgdesc="A GTK+ based e-mail client, without libgdata support"
-arch=('x86_64' 'i686' 'armv7h')
+pkgver=3.17.8
+pkgrel=1
+pkgrel+=.nonprism1
+pkgdesc="A GTK+ based e-mail client."
+pkgdesc="${pkgdesc//./}, without libgdata support"
+arch=('x86_64')
+arch+=('armv7h' 'i686')
license=('GPL3')
-url="http://www.claws-mail.org"
-depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'compface'
- 'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('spamassassin' 'bogofilter' 'valgrind'
+url="https://www.claws-mail.org"
+depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
+ 'libetpan' 'compface' 'libsm' 'dbus-glib')
+makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
# dependencies for plugins
- 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk' 'libytnef' 'libical' 'dillo'
+ 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
+ 'dillo' 'python' 'gumbo-parser'
# deps to build the docs
- 'docbook-utils')
- #'libchamplain' needed for geolocation plugin, disabled for now - most time it's not compatible with current gnome releases
-optdepends=('python2: needed for some tools and python plugin'
+ 'docbook-utils' 'texlive-formatsextra')
+makedepends=(${makedepends[@]/libgdata/})
+optdepends=('python: needed for some tools'
'perl: needed for some tools and perl plugin'
'spamassassin: adds support for spamfiltering'
'bogofilter: adds support for spamfiltering'
@@ -35,54 +41,41 @@ optdepends=('python2: needed for some tools and python plugin'
'poppler-glib: for pdf viewer plugin'
'ghostscript: for pdf viewer plugin'
'libical: for vcalendar plugin'
- 'dillo: for html viewer plugin')
-replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
-conflicts=('claws-mail-extra-plugins')
+ 'dillo: for html viewer plugin'
+ 'gumbo-parser: for litehtml plugin')
provides=('claws')
-source=(http://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
- dillo-plugin.diff)
-sha256sums=('c212133d3d962129d8c7995c1c7d973faef2a8914481c0c74578217bf4c897ab'
+source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
+ bash_completion)
+sha256sums=('cdb7b2814995d6f4a9c3b1f0bc1467ed5c3cf2a5e0da1730aaa25a8accafddaf'
'SKIP'
- 'ab08ca513145e847d30a29d9e5a9ae63b94222423e88c1b375fd5cfcb427d6c5')
+ '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
-prepare() {
- cd ${pkgname}-${pkgver}
- # upstream reintroduction of dillo plugin - after fancy plugin dropped
- patch -Np1 -i ../dillo-plugin.diff
-
- autoreconf -vfi
- sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
- sed -i 's:python -c:python2 -c:g' configure
-}
-
build() {
- cd ${pkgname}-${pkgver}
-
- # fixes for python2
- export PYTHON="/usr/bin/python2"
-
+ cd "${pkgname}"-${pkgver}
./configure --prefix=/usr --disable-static \
--enable-enchant \
--enable-gnutls \
--enable-ldap \
--enable-crash-dialog \
+ --disable-gdata-plugin \
--enable-pgpmime-plugin \
--enable-spamassassin-plugin \
- --enable-bogofilter-plugin \
- --disable-gdata-plugin #--help
+ --enable-bogofilter-plugin
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd ${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd "${pkgname}"-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
# install extra tools
cd tools
- install -m755 -d ${pkgdir}/usr/lib/claws-mail/tools
- for files in *.pl *.py *.sh kdeservicemenu multiwebsearch.conf tb2claws-mail update-po uudec uuooffice README; do
- cp -arv $files ${pkgdir}/usr/lib/claws-mail/tools/${i}
+ install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
+ for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
+ cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
done
}