summaryrefslogtreecommitdiff
path: root/nonprism-testing/geoclue/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism-testing/geoclue/PKGBUILD')
-rw-r--r--nonprism-testing/geoclue/PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/nonprism-testing/geoclue/PKGBUILD b/nonprism-testing/geoclue/PKGBUILD
new file mode 100644
index 000000000..c9601519c
--- /dev/null
+++ b/nonprism-testing/geoclue/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: György Balló <ballogy@freestart.hu>
+# Maintainer: Freemor freemor@freemor.ca
+
+# Rationale:
+# Privacy is a right. This anti-privacy code is being included in more and more projects
+# time for a drop in privvacy safe version.
+
+
+# To do:
+# replace geoclue.conf with a version that has all tracking set to false
+
+
+pkgname=geoclue
+pkgver=2.5.5+6+gea52170
+pkgrel=1
+pkgrel+=.nonprism1
+pkgdesc="Modular geoinformation service built on the D-Bus messaging system"
+arch=(x86_64)
+url="https://www.freedesktop.org/wiki/Software/GeoClue/"
+license=(LGPL)
+depends=(libsoup json-glib libmm-glib avahi geocode-glib)
+makedepends=(systemd gobject-introspection git vala meson gtk-doc libnotify)
+optdepends=('libnotify: Demo Agent')
+provides=("geoclue2=$pkgver-$pkgrel")
+conflicts=(geoclue2)
+replaces=(geoclue2)
+backup=(etc/geoclue/geoclue.conf)
+_commit=ea52170f62da6cbdb8b5ff093c75cb639df9f11d # master
+source=("git+https://gitlab.freedesktop.org/geoclue/geoclue.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+}
+
+build() {
+ arch-meson $pkgname build -D 3g-source=false -D cdma-source=false -D modem-gps-source=false -D nmea-source=false -D mozilla-api-key=""
+
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+
+ echo 'u geoclue - "Geoinformation service" /var/lib/geoclue' |
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
+
+ echo 'd /var/lib/geoclue 0755 geoclue geoclue' |
+ install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
+}
+