summaryrefslogtreecommitdiff
path: root/libre/vhba-module-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/vhba-module-libre/PKGBUILD')
-rw-r--r--libre/vhba-module-libre/PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/libre/vhba-module-libre/PKGBUILD b/libre/vhba-module-libre/PKGBUILD
index 952935c35..c32ba0309 100644
--- a/libre/vhba-module-libre/PKGBUILD
+++ b/libre/vhba-module-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 112896 2014-06-09 12:14:50Z foutrelis $
+# $Id: PKGBUILD 113281 2014-06-17 08:06:25Z tpowa $
# Maintainer (Arch): Ray Rashif <schiv@archlinux.org>
# Contributor (Arch): Mateusz Herych <heniekk@gmail.com>
# Contributor (Arch): Charles Lindsay <charles@chaoslizard.org>
@@ -7,23 +7,33 @@
_pkgname=vhba-module
pkgname=vhba-module-libre
pkgver=20130607
-_extramodules=extramodules-3.14-LIBRE
-pkgrel=27
+_extramodules=extramodules-3.15-LIBRE
+pkgrel=29
pkgdesc="Kernel module that emulates SCSI devices (built for the linux-libre kernel package)"
arch=('i686' 'x86_64' 'mips64el')
url="http://cdemu.sourceforge.net/"
license=('GPL')
-depends=('linux-libre>=3.14' 'linux-libre<3.15')
-makedepends=('linux-libre-headers>=3.14' 'linux-libre-headers<3.15')
+depends=('linux-libre>=3.15' 'linux-libre<3.16')
+makedepends=('linux-libre-headers>=3.15' 'linux-libre-headers<3.16')
options=(!makeflags)
install=$_pkgname.install
replaces=('vhba-module')
conflicts=('vhba-module')
provides=("vhba-module=$pkgver")
source=("http://downloads.sourceforge.net/cdemu/$_pkgname-$pkgver.tar.bz2"
- '60-vhba.rules')
+ '60-vhba.rules'
+ '0001-VHBA-module-define-scmd_dbg-and-scmd_warn-macros-onl.patch')
md5sums=('660df41d08b1fd86baad1f16a0264438'
- '4dc37dc348b5a2c83585829bde790dcc')
+ '4dc37dc348b5a2c83585829bde790dcc'
+ '8c929ef662de89f348d277983cbb3952')
+
+prepare() {
+ cd $_pkgname-$pkgver
+
+ # Fix build with Linux-libre 3.15
+ # http://sourceforge.net/p/cdemu/bugs/76/
+ patch -Np2 -i ../0001-VHBA-module-define-scmd_dbg-and-scmd_warn-macros-onl.patch
+}
build() {
cd $_pkgname-$pkgver