summaryrefslogtreecommitdiff
path: root/libre/uboot-usbarmory-linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/uboot-usbarmory-linux-libre/PKGBUILD')
-rw-r--r--libre/uboot-usbarmory-linux-libre/PKGBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/libre/uboot-usbarmory-linux-libre/PKGBUILD b/libre/uboot-usbarmory-linux-libre/PKGBUILD
deleted file mode 100644
index 72ab2db42..000000000
--- a/libre/uboot-usbarmory-linux-libre/PKGBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# U-Boot: Inverse Path USB armory
-# Maintainer (Arch): Kevin Mihelich <kevin@archlinuxarm.org>
-# Maintainer (Arch): Jason Plum <jplum@archlinuxarm.org>
-# Contributor: André Silva <emulatorman@parabola.nu>
-
-buildarch=4
-
-_pkgname=linux-libre
-pkgname=uboot-usbarmory-${_pkgname}
-pkgver=2015.04
-pkgrel=1
-pkgdesc="U-Boot for USB Armory (built for the linux-libre kernel package)"
-arch=('armv7h')
-url="http://git.denx.de/u-boot.git/"
-license=('GPL')
-makedepends=('bc')
-depends=('linux-libre')
-replaces=('uboot-usbarmory')
-install=${pkgname}.install
-backup=(boot/${pkgname}/boot.txt boot/${pkgname}/boot.scr)
-source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
- '0001-parabola-arm-modifications.patch'
- 'boot.txt'
- 'mkscr')
-md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
- '2ca10f4a7eeb0073035263fbbf3dd33a'
- 'eb83db44c372a6ff3349e026083f15f9'
- '021623a04afd29ac3f368977140cfbfd')
-
-prepare() {
- cd u-boot-${pkgver}
-
- patch -Np1 -i ../0001-parabola-arm-modifications.patch
-}
-
-build() {
- cd u-boot-${pkgver}
-
- unset CFLAGS CXXFLAGS LDFLAGS
-
- make distclean
- make usbarmory_config
- make
-}
-
-package() {
- cd u-boot-${pkgver}
-
- install -d "${pkgdir}/boot/${pkgname}"
- install -Dm644 u-boot.imx "${pkgdir}/boot/${pkgname}"
-
- install -Dm644 ../boot.txt "${pkgdir}/boot/${pkgname}"/boot.txt
- tools/mkimage -A arm -O linux -T script -C none -n "U-Boot boot script" -d ../boot.txt "${pkgdir}/boot/${pkgname}"/boot.scr
- install -Dm755 ../mkscr "${pkgdir}/boot/${pkgname}"/mkscr
-}