summaryrefslogtreecommitdiff
path: root/libre/texinfo-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/texinfo-static/PKGBUILD')
-rw-r--r--libre/texinfo-static/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/libre/texinfo-static/PKGBUILD b/libre/texinfo-static/PKGBUILD
new file mode 100644
index 000000000..2f57d4ce9
--- /dev/null
+++ b/libre/texinfo-static/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Márcio Silva <coadde@parabola.nu>
+# based of texinfo
+
+_pkgname=texinfo
+pkgname=texinfo-static
+pkgver=6.1
+pkgrel=1
+pkgdesc='GNU documentation system for on-line information and printed output (static libraries only)'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://www.gnu.org/software/texinfo/'
+license=('GPL3')
+depends=('ncurses-static' 'perl-static' 'texinfo')
+options=('staticlibs')
+source=(ftp://ftp.gnu.org/pub/gnu/$_pkgname/$_pkgname-$pkgver.tar.xz{,.sig}
+ texinfo-6.0-disable-failing-info-test.patch)
+md5sums=('1d7ec1888fae00730693597852b00cde'
+ 'SKIP'
+ '8bfaa21315a8a6184811de8478005d22')
+validpgpkeys=('EAF669B31E31E1DECBD11513DDBC579DAB37FBA9') # Gavin Smith
+
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -p1 -i ../texinfo-6.0-disable-failing-info-test.patch
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ make -C $_pkgname-$pkgver check
+}
+
+package() {
+ make -C $_pkgname-$pkgver DESTDIR="$pkgdir" install
+
+ # remove conflicting files
+ rm -vr ${pkgdir}/usr/{bin,share}
+ rm -v ${pkgdir}/usr/lib/$_pkgname/*.so
+}