summaryrefslogtreecommitdiff
path: root/libre/syslinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/syslinux/PKGBUILD')
-rw-r--r--libre/syslinux/PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/libre/syslinux/PKGBUILD b/libre/syslinux/PKGBUILD
index 1a76a6825..6269ae93c 100644
--- a/libre/syslinux/PKGBUILD
+++ b/libre/syslinux/PKGBUILD
@@ -1,11 +1,10 @@
-# $Id$
-# Maintainer: Thomas Bächler <thomas@archlinux.org>
+# $Id: PKGBUILD 165001 2012-08-08 15:45:08Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-# Maintainer (Parabola): André Silva <andre.paulista@adinet.com.uy>
+# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
pkgname=syslinux
pkgver=4.05
-pkgrel=4.3
+pkgrel=5
arch=('i686' 'x86_64')
pkgdesc="Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE (Parabola rebranded)"
url="http://syslinux.zytor.com/"
@@ -14,7 +13,7 @@ depends=('perl' 'glibc')
optdepends=('perl-passwd-md5: For md5pass'
'perl-digest-sha1: For sha1pass'
'mtools: For mkdiskimage and syslinux support'
- )
+ 'gptfdisk: For GPT support')
makedepends=('nasm')
backup=('boot/syslinux/syslinux.cfg'
'boot/syslinux/splash.png')
@@ -23,14 +22,8 @@ source=(http://www.kernel.org/pub/linux/utils/boot/syslinux/$pkgname-${pkgver}.t
syslinux-dont-build-dos-windows-targets.patch
syslinux.cfg
syslinux-install_update
- splash.png
- fix-undefined-type-umode_t.patch)
-md5sums=('82299242418385da1274c9479a778cb2'
- '1528c376e43f0eaccaa80d8ad1bc13b4'
- '8dc2afca3739667e892faf04eb97e7b1'
- '680750f73dc2e587ac567d057d485813'
- '0035b6cac6756a384b861eda8d33e4f7'
- '8674f8a0f480f26b705570d699c78a2c')
+ avoid-using-ext2_fs.patch
+ splash.png)
build() {
# Do not try to build syslinux with our default LDFLAGS, it will fail
@@ -38,8 +31,8 @@ build() {
cd "$srcdir"/$pkgname-${pkgver}
# Do not try to build the Windows or DOS installers
patch -p1 -i "$srcdir"/syslinux-dont-build-dos-windows-targets.patch
- # Fix unknown type name 'umode_t' error
- patch -p1 -i "$srcdir"/fix-undefined-type-umode_t.patch
+ # fix #30084
+ patch -Np1 -i "$srcdir"/avoid-using-ext2_fs.patch
# Fix FHS manpage path
sed 's|/usr/man|/usr/share/man|g' -i mk/syslinux.mk
make
@@ -59,3 +52,9 @@ package() {
# move extlinux binary to /usr/sbin
mv "$pkgdir"/sbin/extlinux "$pkgdir"/usr/sbin/extlinux
}
+md5sums=('82299242418385da1274c9479a778cb2'
+ '1528c376e43f0eaccaa80d8ad1bc13b4'
+ '8dc2afca3739667e892faf04eb97e7b1'
+ '680750f73dc2e587ac567d057d485813'
+ '2e2c674a71c0c0bf265d96cfc19ce985'
+ '0035b6cac6756a384b861eda8d33e4f7')