summaryrefslogtreecommitdiff
path: root/libre/sagemath/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/sagemath/PKGBUILD')
-rw-r--r--libre/sagemath/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/libre/sagemath/PKGBUILD b/libre/sagemath/PKGBUILD
index c3a5aa6e7..47c4ff7b7 100644
--- a/libre/sagemath/PKGBUILD
+++ b/libre/sagemath/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 208152 2017-01-20 19:45:48Z arojas $
+# $Id: PKGBUILD 209349 2017-01-29 11:20:25Z arojas $
# Maintainer (Arch): Evgeniy Alekseev <arcanis.arch at gmail dot com>
# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
# Contributor (Arch): Daniel Wallace <danielwallace at gtmanfred dot com>
@@ -11,7 +11,7 @@
pkgname=sagemath
pkgver=7.5.1
-pkgrel=3.parabola1
+pkgrel=4.parabola1
pkgdesc="Free Mathematics Software, free software replacement of Magma, Maple, Mathematica, and Matlab, without nonfree nauty support"
arch=(i686 x86_64 armv7h)
url="http://www.sagemath.org"
@@ -29,29 +29,32 @@ optdepends=('cython2: to compile cython code' 'python2-pkgconfig: to compile cyt
'coxeter3: Coxeter groups implementation' 'cryptominisat2: SAT solver' 'gap-data: for computing Galois groups'
'lrs: Algorithms for linear reverse search used in game theory and for computing volume of polytopes'
'libhomfly: for computing the homfly polynomial of links' 'libbraiding: for computing in braid groups'
- 'python2-pynormaliz: Normaliz backend for polyhedral computations'
+ 'libfes: exhaustive search of solutions for boolean equations' 'python2-pynormaliz: Normaliz backend for polyhedral computations'
'sagemath-jupyter: Jupyter kernel')
makedepends=(cython2 boost ratpoints symmetrica python2-jinja coin-or-cbc libhomfly libbraiding
- mcqd coxeter3 cryptominisat2 modular_decomposition bliss-graphs tdlib python2-pkgconfig meataxe) # libfes
+ mcqd coxeter3 cryptominisat2 modular_decomposition bliss-graphs tdlib python2-pkgconfig meataxe libfes)
conflicts=(sage-mathematics)
replaces=(sage-mathematics)
provides=(sage-mathematics)
source=("$pkgname-$pkgver.tar.gz::https://github.com/sagemath/sage/archive/$pkgver.tar.gz"
- env.patch skip-check.patch cython-sys-path.patch is-package-installed.patch package.patch disable-fes.patch
- jupyter-path.patch test-optional.patch ecm-7.patch increase-rtol.patch sagemath-gslcblas.patch r-no-readline.patch)
+ env.patch skip-check.patch cython-sys-path.patch is-package-installed.patch package.patch
+ jupyter-path.patch test-optional.patch ecm-7.patch increase-rtol.patch sagemath-gslcblas.patch r-no-readline.patch
+ sagemath-no-anal.h.patch sagemath-planarity3.patch fes02.patch)
sha256sums=('3cd9af3e3bfd7f5cc966b7c36168d04b9a1213aa9a7af3286b5d53d40e7653e3'
'9dba04ff13626a7b6c338a8b18a6c27d343f68a547a218533cf773af3dae6635'
'b02b3d2d5620ca20f96adb62b6fef05e4676c0a60983310a1450fdf3d923cb04'
'ff7e034d08ab084fdb193484f7fe3a659ebcd8ab33a2b7177237d65b26de7872'
'd60fb0fbd27991ce9496ca035a54b03334b5b53f244227a8d6e13f3327ce75d2'
'4a2297e4d9d28f0b3a1f58e1b463e332affcb109eafde44837b1657e309c8212'
- '7ab53d30b877dabb6835fbe67a208bef65fa0aaf40221b4d0b58e4b7086bc47a'
'775051aa9076ebf631c8a291af38b6ec4a13c904740dc9da831641d592d8bcd8'
'81d08c6a760f171f3381455b66a6c84789c9f0eefddbe6ca5794075514ad8c3a'
'65ad84c83d5f956fde8eab961f2caad56d64044324c4abc0e56bcd9f44061cb6'
'be925eefeac3f28e639794ddc20d64e6faafd7181804e29417a510224d19ccc7'
'973224f53e9a6fcfaa9c6cb842b02430a601d1c7ce0abb41b3591470d128930c'
- 'ef9f401fa84fe1772af9efee6816643534f2896da4c23b809937b19771bdfbbf')
+ 'ef9f401fa84fe1772af9efee6816643534f2896da4c23b809937b19771bdfbbf'
+ '8126c92a5fc15738c4f7982aadb5a4033230fc2d5da05af9133a96ad1181419e'
+ 'a1c562ebe4538d672404ca3ac2e954a3c955afeb7463f7b4fe6eaa6fa74fe5c7'
+ 'a39da083c038ada797ffc5bedc9ba47455a3f77057d42f86484ae877ef9172ea')
prepare(){
cd sage-$pkgver
@@ -77,14 +80,16 @@ prepare(){
patch -p1 -i ../sagemath-gslcblas.patch
# fix freezes in R interface with readline 7 (Debian)
patch -p1 -i ../r-no-readline.patch
+# fix build with planarity 3 (Debian)
+ patch -p2 -i ../sagemath-planarity3.patch
# Upstream patches
# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
-# patch -p0 -i ../fes02.patch
-# disable fes module, fails to compile
- patch -p0 -i ../disable-fes.patch
+ patch -p1 -i ../fes02.patch
# replace is_package_installed usage http://trac.sagemath.org/ticket/20377
patch -p1 -i ../is-package-installed.patch
+# Allow compiling without pari's anal.h https://trac.sagemath.org/ticket/22195
+ patch -p1 -i ../sagemath-no-anal.h.patch
# use python2
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' -e 's|exec python|exec python2|' -i src/bin/*