summaryrefslogtreecommitdiff
path: root/libre/qupzilla/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qupzilla/PKGBUILD')
-rw-r--r--libre/qupzilla/PKGBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/libre/qupzilla/PKGBUILD b/libre/qupzilla/PKGBUILD
deleted file mode 100644
index f98774502..000000000
--- a/libre/qupzilla/PKGBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# $Id: PKGBUILD 212303 2017-02-14 07:32:02Z arojas $
-# Maintainer (Arch): speps <speps at aur dot archlinux dot org>
-# Maintainer: André Silva <emulatorman@parabola.nu>
-
-pkgname=qupzilla
-pkgver=2.1.1
-pkgrel=1.parabola1
-pkgdesc="Cross-platform QtWebEngine browser, without non-privacy search engines"
-arch=(i686 x86_64 armv7h)
-url="http://www.qupzilla.com/"
-license=('GPL3')
-depends=('qt5-webengine' 'qt5-x11extras' 'qt5-svg' 'hicolor-icon-theme')
-makedepends=('qt5-tools' 'kwallet' 'libgnome-keyring')
-optdepends=('bash-completion: bash completion support' 'kwallet: kf5 kwallet integration'
- 'libgnome-keyring: gnome keyring integration')
-provides=('qupzilla-qt5')
-conflicts=('qupzilla-qt5')
-replaces=('qupzilla-qt5')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/QupZilla/qupzilla/archive/v$pkgver.tar.gz"
- 'searchenginesmanager.cpp.sed'
- 'speeddial.cpp.sed'
- 'start.html.sed')
-md5sums=('ee7f041080df526d69081f8de8e87ed9'
- '7c6692810cc521633e0a6d9a076334e1'
- '0f166fa102af975b3b8ac030d477e9b8'
- '77120a0c39ba8254e5b2c273910f029a')
-
-prepare() {
- # configure
- export USE_WEBGL=true \
- QUPZILLA_PREFIX=/usr/ \
- KDE_INTEGRATION=true \
- GNOME_INTEGRATION=true
-
- # remove Google and Youtube support, replaces it to DDG HTML
- cd $pkgname-$pkgver
- sed -i -f $srcdir/searchenginesmanager.cpp.sed src/lib/opensearch/searchenginesmanager.cpp
- sed -i -f $srcdir/speeddial.cpp.sed src/lib/plugins/speeddial.cpp
- sed -i -f $srcdir/start.html.sed src/lib/data/html/start.html
-}
-
-build() {
- cd $pkgname-$pkgver
- qmake
- make
-}
-
-package() {
- cd $pkgname-$pkgver
- make INSTALL_ROOT="$pkgdir/" install
-
- # zsh completion
- install -Dm644 linux/completion/_$pkgbase \
- "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
-}
-
-# vim:set ts=2 sw=2 et: