summaryrefslogtreecommitdiff
path: root/libre/python-reportlab-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/python-reportlab-libre/PKGBUILD')
-rw-r--r--libre/python-reportlab-libre/PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/libre/python-reportlab-libre/PKGBUILD b/libre/python-reportlab-libre/PKGBUILD
index e0dfc9d9c..7ead18cba 100644
--- a/libre/python-reportlab-libre/PKGBUILD
+++ b/libre/python-reportlab-libre/PKGBUILD
@@ -1,18 +1,20 @@
-# $Id: PKGBUILD 29478 2010-10-14 14:58:41Z angvp $
-# Maintainer: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
+# $Id: PKGBUILD 67753 2012-03-14 10:35:58Z giovanni $
+# Maintainer:
+# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
# Contributor: William Rea <sillywilly@gmail.com>
# Maintainer (Parabola): fauno <fauno@kiwwwi.com.ar>
# Contributor: borgo <nomail>
+# Contributor (Parabola): André Silva <emulatorman@lavabit.com>
pkgname=python-reportlab-libre
_origname=reportlab
pkgver=2.5
-pkgrel=1
+pkgrel=2
pkgdesc="A proven industry-strength PDF generating solution"
arch=('i686' 'x86_64')
depends=('python2' 'freetype2' 'ttf-bitstream-vera' 'gsfonts' 'python-imaging')
license=('custom')
-source=(http://www.reportlab.org/ftp/${_origname}-$pkgver.tar.gz
+source=(http://www.reportlab.com/ftp/${_origname}-$pkgver.tar.gz
free-fonts.patch)
url="http://www.reportlab.org/rl_toolkit.html"
md5sums=('cdf8b87a6cf1501de1b0a8d341a217d3'
@@ -34,6 +36,6 @@ build() {
rm -f reportlab/fonts/Vera* reportlab/fonts/bitstream-vera-license.txt
patch -p1 -i $srcdir/free-fonts.patch
- python2 setup.py install --root=$pkgdir
+ python2 setup.py install --root=$pkgdir --optimize=1
install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
}