summaryrefslogtreecommitdiff
path: root/libre/parabolaweb-utils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/parabolaweb-utils/PKGBUILD')
-rw-r--r--libre/parabolaweb-utils/PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/libre/parabolaweb-utils/PKGBUILD b/libre/parabolaweb-utils/PKGBUILD
index 5fdd12bdb..4220394dc 100644
--- a/libre/parabolaweb-utils/PKGBUILD
+++ b/libre/parabolaweb-utils/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
-. helper.sh
+. "${startdir:-.}/helper.sh"
# provides:
-# _get_pkgver
# _get_depends
# _get_depends_nover (no version requirements)
pkgname=parabolaweb-utils
-pkgver=`_get_pkgver`
-pkgrel=8
+pkgver=20120425.0657
pkgdesc="Utils for the Parabola website"
-arch=('any')
url="https://projects.parabolagnulinux.org/parabolaweb.git/"
license=('GPL2')
+
+pkgrel=1
+epoch=1
+arch=('any')
depends=(
'python2' # duh
'python2-flup' # for fcgi
@@ -20,11 +21,9 @@ depends=(
'git' # used in parabolaweb-download
'libretools' # used in parabolaweb-{download,update} (libremessages)
`_get_depends`)
-backup=('etc/conf.d/parabolaweb')
-
-export pkgver
-
+conflicts=('django>=1.5') # hold it at 1.4
makedepends=(makepkg-git)
+backup=('etc/conf.d/parabolaweb')
source=(git://parabolagnulinux.org/parabolaweb.git
parabolaweb-download
@@ -34,6 +33,13 @@ source=(git://parabolagnulinux.org/parabolaweb.git
parabolaweb.service
parabolaweb.conf)
+pkgver() {
+ cd "$srcdir/parabolaweb"
+ # get the date requirements_prod.txt was last modified
+ gitdate="$(git log -n1 --date=iso --format=format:'%cd' ./requirements_prod.txt)"
+ date -u +%Y%m%d.%H%M -d "$gitdate"
+}
+
build() {
:
}