summaryrefslogtreecommitdiff
path: root/libre/p7zip-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/p7zip-libre/PKGBUILD')
-rw-r--r--libre/p7zip-libre/PKGBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/libre/p7zip-libre/PKGBUILD b/libre/p7zip-libre/PKGBUILD
index fb803b74c..dc3e1562f 100644
--- a/libre/p7zip-libre/PKGBUILD
+++ b/libre/p7zip-libre/PKGBUILD
@@ -1,15 +1,15 @@
# $Id: PKGBUILD 203246 2014-01-06 19:32:24Z bpiotrowski $
-# Contributor: Thayer Williams <thayer@archlinux.org>
-# Contributor: Hugo Doria <hugo@archlinux.org>
-# Contributor: TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
-# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor (Arch): Thayer Williams <thayer@archlinux.org>
+# Contributor (Arch): Hugo Doria <hugo@archlinux.org>
+# Contributor (Arch): TuxSpirit<tuxspirit@archlinux.fr> 2007/11/17 21:22:36 UTC
+# Contributor (Arch): Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer (Arch): Gaetan Bisson <bisson@archlinux.org>
pkgname=p7zip-libre
_pkgname=${pkgname%-libre}
pkgver=9.20.1
-pkgrel=9.2
-pkgdesc='Command-line version of the 7zip compressed file archiver, without nonfree unrar support'
+pkgrel=9.4
+pkgdesc='Command-line version of the 7zip compressed file archiver, without nonfree decompression engine for RAR archives'
url='http://p7zip.sourceforge.net/'
license=('GPL')
arch=('i686' 'x86_64' 'mips64el')
@@ -20,34 +20,36 @@ depends=('gcc-libs' 'bash')
optdepends=('wxgtk2.8: GUI'
'desktop-file-utils: desktop entries')
makedepends=('yasm' 'nasm' 'wxgtk2.8')
-mksource=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}_${pkgver}_src_all.tar.bz2"
- 'p7zip-libre.patch' 'parent-folder-icon.patch')
+mksource=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}_${pkgver}_src_all.tar.bz2")
source=("https://repo.parabolagnulinux.org/other/${pkgname}/${pkgname}_${pkgver}_src_all.tar.bz2"
- '7zFM.desktop')
-mksha1sums=('1cd567e043ee054bf08244ce15f32cb3258306b7'
- '8fc0e6e80aeec371a8c80e7a6082594ac6d08aed'
- '335a4a38d457d2b0166538d514ffd3c183bbb37f')
-sha1sums=('ef3f668f5d75941f7a3ba7873e4b234b9f97445b'
- 'f2c370d6f1b286b7ce9a2804e22541b755616a40')
+ '7zFM.desktop' 'libre.patch')
+mksha1sums=('1cd567e043ee054bf08244ce15f32cb3258306b7')
+sha1sums=('4e5ba097a90f3e00ad072023030c87f0707733b8'
+ 'f2c370d6f1b286b7ce9a2804e22541b755616a40'
+ 'bd929fdcbc05dcc783f7fa7d156ed15d38b0b4b3')
options=('!makeflags')
install=install
mksource() {
cd "${srcdir}/${_pkgname}_${pkgver}"
- msg "Removing unRar"
- # Generate patch
- # sed -e '/Rar/d' -i makefile*
- # find -name '*Rar*' -print0 | xargs -0 rm -rvf
- # Remove Rar mentions in CPP/7zip/Bundles/Format7zFree/makefile
- patch -Np1 -i ../p7zip-libre.patch
- msg 'Replacing the parent folder icon'
+
+ # Remove nonfree decompression engine for RAR archives
+ rm -rv CPP/7zip/{Archive,Compress}/Rar
+ rm -v CPP/7zip/Compress/{Rar{2,3}Decoder.{cpp,h},Rar3Vm.{cpp,h},RarCodecsRegister.cpp}
+ rm -v CPP/7zip/Crypto/{Rar20Crypto,RarAes}.{cpp,h}
+ rm -v DOCS/unRarLicense.txt
+
+ # Remove nonfree parent folder icon
rm CPP/7zip/UI/FileManager/res/ParentFolder.h
- patch -Np1 -i ../parent-folder-icon.patch
}
prepare() {
cd "${srcdir}/${_pkgname}_${pkgver}"
+
+ # remove rar and parent folder icon references
+ patch -Np1 -i ../libre.patch
+
rm GUI/kde4/p7zip_compress.desktop
[[ $CARCH = x86_64 ]] \
&& cp makefile.linux_amd64_asm makefile.machine \