summaryrefslogtreecommitdiff
path: root/libre/p11-kit-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/p11-kit-static/PKGBUILD')
-rw-r--r--libre/p11-kit-static/PKGBUILD60
1 files changed, 0 insertions, 60 deletions
diff --git a/libre/p11-kit-static/PKGBUILD b/libre/p11-kit-static/PKGBUILD
deleted file mode 100644
index 171146594..000000000
--- a/libre/p11-kit-static/PKGBUILD
+++ /dev/null
@@ -1,60 +0,0 @@
-# Maintainer: Márcio Silva <coadde@parabola.nu>
-# based of p11-kit
-
-_pkgname=p11-kit
-pkgname=p11-kit-static
-pkgver=0.23.2
-pkgrel=1
-pkgdesc="Library to work with PKCS#11 modules (static libraries only)"
-arch=(i686 x86_64 armv7h)
-url="http://p11-glue.freedesktop.org"
-license=('BSD')
-depends=('libtasn1-static' 'libffi-static' 'p11-kit')
-options=('staticlibs')
-source=($url/releases/$_pkgname-$pkgver.tar.gz{,.sig}
- libnssckbi-compat.patch)
-sha256sums=('ba726ea8303c97467a33fca50ee79b7b35212964be808ecf9b145e9042fdfaf0'
- 'SKIP'
- '8f763cdbc6c0ca6c5a7898f9fd6f3018b7ac5b1aca36f67c6c813343c2962962')
-validpgpkeys=('C0F67099B808FB063E2C81117BFB1108D92765AF')
-
-prepare() {
- cd $_pkgname-$pkgver
-
- # Build and install an additional library (libnssckbi-p11-kit.so) which
- # is a copy of p11-kit-trust.so but uses the same label for root certs as
- # libnssckbi.so ("Builtin Object Token" instead of "Default Trust")
- # https://bugs.freedesktop.org/show_bug.cgi?id=66161
- patch -Np1 -i ../libnssckbi-compat.patch
-
- autoreconf -vi
-
- sed -i '\|^if[ ]test[ ]["][$]enable_static["][ ][=][ ]["]yes["][;][ ]then$|,+3 d
- ' configure
-}
-
-build() {
- cd $_pkgname-$pkgver
-
- ./configure \
- --prefix=/usr --enable-static \
- --with-module-path=/usr/lib/pkcs11 \
- --with-trust-paths=/etc/ca-certificates/trust-source:/usr/share/ca-certificates/trust-source
- make
-}
-
-check() {
- cd $_pkgname-$pkgver
- make check
-}
-
-package() {
- cd $_pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-
- # remove conflicting files
- rm -vr ${pkgdir}/usr/{bin,etc,include,lib/{pkgconfig,$_pkgname},share}
- rm -v ${pkgdir}/usr/lib/{,pkcs11/}*.so*
-}
-
-# vim:set ts=2 sw=2 et: