summaryrefslogtreecommitdiff
path: root/libre/mcomix-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/mcomix-libre/PKGBUILD')
-rw-r--r--libre/mcomix-libre/PKGBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/libre/mcomix-libre/PKGBUILD b/libre/mcomix-libre/PKGBUILD
index 97c3bde0f..c512a26cd 100644
--- a/libre/mcomix-libre/PKGBUILD
+++ b/libre/mcomix-libre/PKGBUILD
@@ -1,13 +1,13 @@
# $Id: PKGBUILD 106934 2014-03-10 18:30:38Z schuay $
-# Maintainer: schuay <jakob.gruber@gmail.com>
-# Contributor: Ray Powell <ray_al@xphoniexx.net>
-# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
+# Maintainer (Arch): schuay <jakob.gruber@gmail.com>
+# Contributor (Arch): Ray Powell <ray_al@xphoniexx.net>
+# Maintainer: André Silva <emulatorman@parabola.nu>
_pkgname=mcomix
pkgname=mcomix-libre
pkgver=1.00
-pkgrel=6
-pkgdesc="A user-friendly, customizable image viewer specifically designed to handle comic books, without nonfree unrar recommendation"
+pkgrel=6.2
+pkgdesc="A user-friendly, customizable image viewer specifically designed to handle comic books, without nonfree unrar support"
arch=('any')
url="http://sourceforge.net/projects/mcomix/"
license=('GPL')
@@ -19,7 +19,17 @@ replaces=('mcomix' 'comix')
provides=("mcomix=${pkgver}")
install='mcomix.install'
source=("http://downloads.sourceforge.net/project/mcomix/MComix-${pkgver}/mcomix-${pkgver}.tar.bz2"
- 'zoom.patch')
+ 'zoom.patch'
+ 'libre.patch')
+
+prepare() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ # Remove nonfree unRAR support
+ rm -v mcomix/archive/rar{,file}.py
+ rm -v mime/icons/*/application-x-cbr.png
+ patch -Np1 -i ${srcdir}/libre.patch
+}
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
@@ -53,4 +63,5 @@ package() {
}
md5sums=('3a916dd9da17043ab59ccd17e26eb932'
- 'c80705bf6f132bfba20dcb84b79c9cb7')
+ 'c80705bf6f132bfba20dcb84b79c9cb7'
+ 'cbb3730d3bed153b88208163e83d60e2')