summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index db1d1c223..663e3c916 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 212093 2014-05-06 20:49:41Z tpowa $
+# $Id: PKGBUILD 212325 2014-05-12 18:58:13Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
@@ -12,7 +12,7 @@ pkgbase=linux-libre # Build stock -LIBRE kernel
_basekernel=3.14
_sublevel=3
pkgver=${_basekernel}.${_sublevel}
-pkgrel=1
+pkgrel=2
_lxopkgver=${_basekernel}.3 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
@@ -21,6 +21,7 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
+ 'CVE-2014-0196.patch'
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -43,6 +44,7 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.xz")
sha256sums=('477555c709b9407fe37dbd70d3331ff9dde1f9d874aba2741f138d07ae6f281b'
'fcd8398a41a7e55e44123857342fd9041ae1bdacbcf8c5099a53293c96e6fba6'
+ '56d6dc13617645184e2a14b2ee466ccba5241961953f4950aed7377bc34902d7'
'71891ae6903598f4686e86fdb0d371ff9e179e8dac1d2cf60ca16c5190916745'
'fca0060bde385e2c292489087af0aa5f48da594221a6d162fc6f8ba2159571e8'
'dfe01c93d83cdac9ca502715ceb6ac9502d327c939fec2e3052a5a58422dc176'
@@ -81,6 +83,9 @@ prepare() {
# add freedo as boot logo
patch -p1 -i "${srcdir}/boot-logo.patch"
+ # fix upstream CVE-2014-0196
+ patch -p1 -i "${srcdir}/CVE-2014-0196.patch"
+
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git