summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 2a8d5800c..94922e661 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -22,7 +22,7 @@ _replacesoldmodules=() # '%' gets replaced with _kernelname
_srcname=linux-${_pkgbasever%-*}
_archpkgver=${_pkgver%-*}
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=1.1
rcnrel=armv7-x0
arch=('i686' 'x86_64' 'armv7h')
url="https://linux-libre.fsfla.org/"
@@ -58,6 +58,7 @@ source=(
'0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch'
'0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch'
# other patches
+ 'change-console-loglevel-motormouth.patch'
'0001-usb-serial-gadget-no-TTY-hangup-on-USB-disconnect-WI.patch'
'0002-fix-Atmel-maXTouch-touchscreen-support.patch'
'0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
@@ -102,6 +103,7 @@ sha512sums=('c6805b3649cd71cfef272384958b33da23a00908e795592470bf711dd67886ab7d7
'1e718ff5fa0e047056ecdaa25d5c8c4b733a8e8681e9cd8f274d447ae46db8818db3c6c1339b638b6df8adbe97734133c0f37064e81857b9c48c1b10ba05e9bb'
'ab0ed8724eed15dad76de3174f7c8210f889079be6aea1d2eae164f08ffa49cc4d32ad9e514351a62b755ec7d6d925fb287b1d21e121405e48c19be411580a30'
'6c3b29bd2ffea93bf6a5caff8f6be97a701aa8a40cbb07256f066d40505616096e029e0435ac03dce3a205704c250afdbbfaaa372870e3b3d96a3a482b1af8e5'
+ '0a1a18aa8a6cbf1bab406d356786d2c35fe52608c25bef8beefe440b8a015ba59375106f8b04051ae2225e158420875a82ee07d5b88a2f2087afeb102e8966c0'
'02af4dd2a007e41db0c63822c8ab3b80b5d25646af1906dc85d0ad9bb8bbf5236f8e381d7f91cf99ed4b0978c50aee37cb9567cdeef65b7ec3d91b882852b1af'
'b8fe56e14006ab866970ddbd501c054ae37186ddc065bb869cf7d18db8c0d455118d5bda3255fb66a0dde38b544655cfe9040ffe46e41d19830b47959b2fb168'
'ac301d5bd282e1d336bf71ad9d1085f79f1e89cdd7daf4d9862d11bb82b3fc8eabf07fdff4603dae7f1ef99c0d8f0b93ef276bef794428d69e971335bc783b57'
@@ -185,6 +187,12 @@ prepare() {
# https://labs.parabola.nu/issues/877
# http://www.fsfla.org/pipermail/linux-libre/2015-November/003202.html
patch -p1 -i ../0002-fix-Atmel-maXTouch-touchscreen-support.patch
+
+ if [ "${CARCH}" = "x86_64" ] || [ "${CARCH}" = "i686" ]; then
+ # set CONSOLE_LOGLEVEL_MOTORMOUTH to 1
+ # https://labs.parabola.nu/issues/1754
+ patch -p1 -i ../change-console-loglevel-motormouth.patch
+ fi
cat ../config.${CARCH} - >.config <<END
CONFIG_LOCALVERSION="${_kernelname}"