summaryrefslogtreecommitdiff
path: root/libre/linux-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/linux-libre/PKGBUILD')
-rw-r--r--libre/linux-libre/PKGBUILD37
1 files changed, 15 insertions, 22 deletions
diff --git a/libre/linux-libre/PKGBUILD b/libre/linux-libre/PKGBUILD
index 9103fd2a5..55cada048 100644
--- a/libre/linux-libre/PKGBUILD
+++ b/libre/linux-libre/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 178202 2013-02-18 00:58:40Z foutrelis $
+# $Id: PKGBUILD 178342 2013-02-20 12:32:29Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Maintainer: Thomas Baechler <thomas@archlinux.org>
# Maintainer (Parabola): Nicolás Reynolds <fauno@kiwwwi.com.ar>
@@ -9,18 +9,19 @@
pkgbase=linux-libre # Build stock -LIBRE kernel
#pkgbase=linux-libre-custom # Build kernel with a different name
-_basekernel=3.7
-_sublevel=9
-pkgver=${_basekernel}.${_sublevel}
+_basekernel=3.8
+#_sublevel=9
+#pkgver=${_basekernel}.${_sublevel}
+pkgver=${_basekernel}
pkgrel=1
-_lxopkgver=${_basekernel}.8 # nearly always the same as pkgver
+#_lxopkgver=${_basekernel}.8 # nearly always the same as pkgver
arch=('i686' 'x86_64' 'mips64el')
url="http://linux-libre.fsfla.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl')
options=('!strip')
source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gnu/linux-libre-${_basekernel}-gnu.tar.xz"
- "http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
+ #"http://linux-libre.fsfla.org/pub/linux-libre/releases/${pkgver}-gnu/patch-${_basekernel}-gnu-${pkgver}-gnu.xz"
# the main kernel config files
'config.i686' 'config.x86_64'
# standard config files for mkinitcpio ramdisk
@@ -28,25 +29,21 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_basekernel}-gn
'Kbuild'
'Kbuild.platforms'
'boot-logo.patch'
- 'change-default-console-loglevel.patch'
- 'fat-3.6.x.patch'
- "http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
+ 'change-default-console-loglevel.patch')
+ #"http://www.linux-libre.fsfla.org/pub/linux-libre/lemote/gnewsense/pool/debuginfo/linux-patches-${_lxopkgver}-gnu_0loongsonlibre_mipsel.tar.bz2")
md5sums=('06bf9601d859531e7378eb43d4ca7dd3'
- 'bcffd9fa99c4db6905dc6b22d71cb17a'
'53c782740eb3ddf875ad98c31c1bf213'
'71a6f703cb0bee098a76ea42d5836d06'
'e49ac236dfeef709f91a3d993ea7b62c'
'2967cecc3af9f954ccc822fd63dca6ff'
'8267264d9a8966e57fdacd1fa1fc65c4'
'04b21c79df0a952c22d681dd4f4562df'
- '9d3c56a4b999c8bfbd4018089a62f662'
- '88d501404f172dac6fcb248978251560'
- '5296bf025db8b17613bc7205459564f0')
-if [ "$CARCH" != "mips64el" ]; then
- # Don't use the Loongson-specific patches on non-mips64el arches.
- unset source[${#source[@]}-1]
- unset md5sums[${#md5sums[@]}-1]
-fi
+ '9d3c56a4b999c8bfbd4018089a62f662')
+#if [ "$CARCH" != "mips64el" ]; then
+# # Don't use the Loongson-specific patches on non-mips64el arches.
+# unset source[${#source[@]}-1]
+# unset md5sums[${#md5sums[@]}-1]
+#fi
_kernelname=${pkgbase#linux-libre}
_localversionname=-LIBRE
@@ -66,10 +63,6 @@ build() {
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
patch -Np1 -i "${srcdir}/change-default-console-loglevel.patch"
- # fix cosmetic fat issue
- # https://bugs.archlinux.org/task/32916
- patch -Np1 -i "${srcdir}/fat-3.6.x.patch"
-
if [ "$CARCH" == "mips64el" ]; then
sed -i "s|^EXTRAVERSION.*|EXTRAVERSION =-libre|" Makefile
sed -r "s|^( SUBLEVEL = ).*|\1$_sublevel|" \