summaryrefslogtreecommitdiff
path: root/libre/libretools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libretools/PKGBUILD')
-rw-r--r--libre/libretools/PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/libre/libretools/PKGBUILD b/libre/libretools/PKGBUILD
index ef46c6954..f1fdd8ebf 100644
--- a/libre/libretools/PKGBUILD
+++ b/libre/libretools/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
-# Contributor: Joshua Haase <hahj87@gmail.com>
+# Contributor (Arch): Joshua Haase <hahj87@gmail.com>
# Contributor: fauno <fauno@kiwwwi.com.ar>
# Contributor: Márcio Silva <coadde@parabola.nu>
@@ -9,11 +9,11 @@ pkgdesc="Programs for Parabola development"
url="https://projects.parabolagnulinux.org/packages/libretools.git/"
license=('GPL3' 'GPL2')
-pkgver=20140322
-_libretools_commit=ff15727c30e5b9af5225869e38cbcfa2b08da6c2
-_devtools_commit=534d2015b45e013b37e1edbb997bd4df27d7b8fd
-md5sums=('36c7ef4d4f7e0b1fc6836babd40bb004'
- 'ec69dffa68829f063224de19bbd55fa9')
+pkgver=20140515
+_libretools_commit=22bb572086ff1c1667d553ac8233fc053a1556f2
+_devtools_commit=d732aae2ca57430f3dd95c0ed4dcc05df4014f91
+md5sums=('fd9d872b8fe28e8d64d76b3ef2d0b6ec'
+ '615db785531757d3a849614bb117fba4')
_packages_url=https://projects.parabolagnulinux.org/packages
source=($_packages_url/libretools.git/snapshot/libretools-$_libretools_commit.tar.bz2
@@ -38,9 +38,10 @@ check() {
}
package_librelib() {
- pkgdesc="Shell library portion of libretools"
+ pkgdesc="The shell library portion of libretools"
+ license=(GPL2)
depends=(
- wget # `aur` and `lib/blacklist.sh`
+ wget # `blacklist`
)
cd "$srcdir/$pkgbase-$_libretools_commit"
@@ -48,6 +49,8 @@ package_librelib() {
}
package_gitget() {
+ pkgdesc="A simple to use downloader for git URLs"
+ license=(GPL2)
depends=("librelib=$pkgver" git)
provides=("libregit=$pkgver")
@@ -62,17 +65,18 @@ package_libretools() {
backup=(etc/libretools.conf etc/libretools.d/chroot.conf etc/libretools.d/librefetch.conf)
install=libretools.install
replaces=(chroottools)
- conflicts=(devtools)
+ conflicts=(devtools chroottools)
depends=(
"librelib=$pkgver"
"gitget=$pkgver" # `createworkdir`
+ "systemd>=212" # force newer systemd
arch-install-scripts # `archroot` uses `pacstrap`
openssh # `librerelease`
rsync # `librerelease` and `makechrootpkg.sh`
subversion # `diff-unfree`
tokyocabinet # `treepkg`
- "systemd>208" # force newer systemd
+ wget # `aur`
)
optdepends=('namcap: to check package files')
@@ -82,6 +86,7 @@ package_libretools() {
package_libretools-mips64el() {
pkgdesc="Scripts for Parabola development (for mips64el architecture)"
+ license=(GPL3)
depends=("$pkgbase=$pkgver"
git # mips-add
)