summaryrefslogtreecommitdiff
path: root/libre/libnl-static/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/libnl-static/PKGBUILD')
-rw-r--r--libre/libnl-static/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/libre/libnl-static/PKGBUILD b/libre/libnl-static/PKGBUILD
deleted file mode 100644
index 9b708731d..000000000
--- a/libre/libnl-static/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Márcio Silva <coadde@parabola.nu>
-# based of libnl
-
-_pkgname=libnl
-pkgname=libnl-static
-pkgver=3.2.27
-pkgrel=1
-pkgdesc="Library for applications dealing with netlink sockets (static libraries only)"
-arch=(i686 x86_64 armv7h)
-url="http://www.infradead.org/~tgr/libnl/"
-license=(GPL)
-depends=(libnl)
-options=('staticlibs')
-source=(https://github.com/thom311/libnl/releases/download/libnl${pkgver//./_}/${_pkgname}-${pkgver}.tar.gz{,.sig})
-sha256sums=('4bbbf92b3c78a90f423cf96260bf419a28b75db8cced47051217a56795f58ec6'
- 'SKIP')
-validpgpkeys=('49EA7C670E0850E7419514F629C2366E4DFC5728') # Thomas Haller
-
-build() {
- cd "$srcdir"/$_pkgname-$pkgver
- ./configure \
- --prefix=/usr \
- --enable-static
- make
-}
-
-package() {
- cd "$srcdir"/$_pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-
- # remove conflicting files
- rm -vr ${pkgdir}/usr/{bin,etc,include,lib/pkgconfig,share}
- rm -v ${pkgdir}/usr/lib/{,$_pkgname/cli/{cls,qdisc}/}*.so*
-}