summaryrefslogtreecommitdiff
path: root/libre/kernel26-libre-lts/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/kernel26-libre-lts/PKGBUILD')
-rw-r--r--libre/kernel26-libre-lts/PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/libre/kernel26-libre-lts/PKGBUILD b/libre/kernel26-libre-lts/PKGBUILD
index 1703e2073..d913988b9 100644
--- a/libre/kernel26-libre-lts/PKGBUILD
+++ b/libre/kernel26-libre-lts/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=('kernel26-libre-lts' 'kernel26-libre-lts-headers') # Build stock -lts k
_kernelname=${pkgname#kernel26-libre}
_basekernel=2.6.32
_preset=kernel26-lts.preset
-pkgver=${_basekernel}.33
+pkgver=${_basekernel}.36
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL2')
@@ -220,8 +220,17 @@ package_kernel26-libre-lts-headers() {
chown -R root.root ${pkgdir}/usr/src/linux-${_kernver}
find ${pkgdir}/usr/src/linux-${_kernver} -type d -exec chmod 755 {} \;
-
+ # strip scripts directory
+ find ${pkgdir}/usr/src/linux-${_kernver}/scripts -type f -perm -u+w 2>/dev/null | while read binary ; do
+ case "$(file -bi "$binary")" in
+ *application/x-sharedlib*) # Libraries (.so)
+ /usr/bin/strip $STRIP_SHARED "$binary";;
+ *application/x-archive*) # Libraries (.a)
+ /usr/bin/strip $STRIP_STATIC "$binary";;
+ *application/x-executable*) # Binaries
+ /usr/bin/strip $STRIP_BINARIES "$binary";;
+ esac
+ done
# remove unneeded architectures
rm -rf ${pkgdir}/usr/src/linux-${_kernver}/arch/{alpha,arm,arm26,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,xtensa}
}
-