summaryrefslogtreecommitdiff
path: root/libre/kdelibs-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/kdelibs-libre/PKGBUILD')
-rw-r--r--[-rwxr-xr-x]libre/kdelibs-libre/PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/libre/kdelibs-libre/PKGBUILD b/libre/kdelibs-libre/PKGBUILD
index 326eae2aa..154da73f3 100755..100644
--- a/libre/kdelibs-libre/PKGBUILD
+++ b/libre/kdelibs-libre/PKGBUILD
@@ -1,12 +1,12 @@
-# $Id: PKGBUILD 170700 2012-11-09 21:01:24Z andrea $
+# $Id: PKGBUILD 173890 2012-12-27 10:10:17Z andrea $
# Maintainer: Andrea Scarpino <andrea@archlinux.org
# Contributor: Pierre Schmitz <pierre@archlinux.de>
# Maintainer (Parabola): André Silva <emulatorman@lavabit.com>
_pkgname=kdelibs
pkgname=kdelibs-libre
-pkgver=4.9.3
-pkgrel=2
+pkgver=4.9.4
+pkgrel=4
pkgdesc="KDE Core Libraries"
arch=('i686' 'x86_64' 'mips64el')
url='https://projects.kde.org/projects/kde/kdelibs'
@@ -15,7 +15,7 @@ depends=('strigi' 'attica' 'libxss' 'soprano' 'krb5' 'grantlee'
'shared-desktop-ontologies' 'qca' 'libdbusmenu-qt' 'polkit-qt'
'shared-mime-info' 'enchant' 'giflib' 'jasper' 'openexr'
'docbook-xsl' 'upower' 'udisks' 'libxcursor' 'phonon' 'qtwebkit'
- 'media-player-info' 'libxtst')
+ 'media-player-info' 'libxtst' 'libutempter')
makedepends=('cmake' 'automoc4' 'avahi' 'libgl' 'hspell' 'mesa')
provides=("kdelibs=$pkgver")
replaces=('kdelibs')
@@ -23,13 +23,13 @@ conflicts=('kdelibs')
install=${_pkgname}.install
source=("http://download.kde.org/stable/${pkgver}/src/${_pkgname}-${pkgver}.tar.xz"
'kde-applications-menu.patch'
- 'use-pythondontwritebytecode.patch'
- 'fix-save-path.patch'
+ '0001-Revert-Also-check-parent-mimetypes-in-protocolForArc.patch'
+ 'fix-crash-on-open-with.patch'
'khtml-fsdg.diff')
-sha1sums=('d5d60c431159b17a753ee7427d9ca129d550e3f8'
+sha1sums=('b2fe70261207a96a26b5d8789379f134e3e070be'
'86ee8c8660f19de8141ac99cd6943964d97a1ed7'
- '1138e78f15faa7221669ea81e313c595000cc953'
- 'e3d2621bd1451fe7f45a454af970fae108614ddd'
+ 'f5d203932f67ab6d87c794e9cb78a3b1a22ef747'
+ '8faa5984ba37e9c6da04bc64f1fe21cd24f1cf07'
'a1502a964081ad583a00cf90c56e74bf60121830')
build() {
@@ -39,8 +39,8 @@ build() {
patch -p1 -i "${srcdir}"/kde-applications-menu.patch
# Fixed upstream
- patch -p1 -i "${srcdir}"/use-pythondontwritebytecode.patch
- patch -p1 -i "${srcdir}"/fix-save-path.patch
+ patch -p1 -i "${srcdir}"/0001-Revert-Also-check-parent-mimetypes-in-protocolForArc.patch
+ patch -p1 -i "${srcdir}"/fix-crash-on-open-with.patch
# Don't ask the user to download a plugin, it's probably nonfree.
patch -p1 -i "${srcdir}"/khtml-fsdg.diff