summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD21
1 files changed, 19 insertions, 2 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index c4801250a..a349c661d 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -37,6 +37,7 @@
# - allow skipping profiling build for x86_64 (_x86_64_skip_pgo)
# - prefer as many system libs as possible, over their vendored couterparts
# - Rebrand to Iceweasel, per the mozilla trademark policy, due to the FSDG changes
+# - set user profile directory to ~/.mozilla/iceweasel
#
# privacy:
# - Remove Google API keys and usage
@@ -62,7 +63,7 @@ epoch=1
pkgver=99.0.1
pkgrel=1
pkgrel+=.parabola1
-_brandingver=95.0-1
+_brandingver=98.0-1
pkgdesc="Standalone web browser derived from Mozilla Firefox"
arch=(x86_64)
arch+=(armv7h i686)
@@ -100,7 +101,7 @@ source_i686=('avoid-libxul-OOM-python-check.patch'
sha256sums=('76d22279ce99588a728bb2d034064be0d5918b5900631f2148d4565b8a72e00b'
'SKIP'
'9cdc2602661717712092d28bb494e5b48e518cb930898aca85eaf21f91f7ef58')
-sha256sums+=('d1b9d98cea5356df97fc5c221830de1ced8f826cb39fac9427c407e3eae54c02'
+sha256sums+=('f3e89499909b172476e931d9ab18b856d0001e3042b3816d1728809536179768'
'SKIP'
'af53bd22378cd87c27438c34dc1daf3f1909735e85c914b56440751a9dc16856'
'a2c71759290dd48c87bf8aacb681040dcaefdabe0d57317de361d2d2d509664b'
@@ -682,4 +683,20 @@ END
# else # anti-feature
# cp -fvt "$startdir" obj/dist/*crashreporter-symbols-full.tar.zst # anti-feature
# fi
+
+ # BEGIN RENAME_PROFILE - temporary
+ # replace binary with a temporary wrapper, to rename the user profile directory
+ # NOTE: prior to v99, if another 'firefox' is installed in addition to iceweasel,
+ # both applications would share a profile, which is not very sane behavior.
+ # TODO: this 'rename-profile.sh' source file, and the following two LOC,
+ # could be removed after a reasonable deprecation period (eg: in 2023)
+ mv "${pkgdir}"/usr/lib/iceweasel/ice{,-}weasel
+ install -Dm755 ../rename-profile.sh "${pkgdir}"/usr/lib/iceweasel/iceweasel
+ # END RENAME_PROFILE
}
+
+
+# BEGIN RENAME_PROFILE - temporary - see note in package()
+depends+=(gxmessage) ; source+=(rename-profile.sh) ;
+sha256sums+=('da332a538662b6f8ebe67c0aee85a12af57a6f20309b1eec9f30add3ac1cbc4f')
+# END RENAME_PROFILE