summaryrefslogtreecommitdiff
path: root/libre/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel-libre/PKGBUILD')
-rw-r--r--libre/iceweasel-libre/PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/libre/iceweasel-libre/PKGBUILD b/libre/iceweasel-libre/PKGBUILD
index 912d053bf..85ede7409 100644
--- a/libre/iceweasel-libre/PKGBUILD
+++ b/libre/iceweasel-libre/PKGBUILD
@@ -13,7 +13,7 @@ _pgo=false
# We're getting this from Debian Sid
_debname=iceweasel
_debver=12.0
-_debrel=3
+_debrel=7
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -49,19 +49,17 @@ source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
libre.patch
iceweasel-install-dir.patch
region.properties
- vendor.js
- gcc47.patch)
+ vendor.js)
md5sums=('b45f57bfe21b0e6db4f0683e794917cb'
- '2b66fb2e51631ef3b07de89ef9d17d0c'
- '552adcf5da3b07757e7fe29c8bd2ec2d'
- '34786fca48963a7bea5d55d17a406c35'
+ '08aa0a949d9cbb26116490f7878a62fe'
+ 'd7ad1c025d2442427a06cc702906ef0d'
+ 'eab149c1994ab14392e55af3abb08e80'
'ac29b01c189f20abae2f3eef1618ffc0'
'a485a2b5dc544a8a2bd40c985d2e5813'
'64be2fab525189c285ee04495d628035'
'e529742c0a425648087bc3ce537fe4c5'
'f1c76e7e244257856a386ca2de69bdf0'
- '0d053487907de4376d67d8f499c5502b'
- '79e471e0bd03b1d4e84fd3a6776bd619')
+ '0d053487907de4376d67d8f499c5502b')
if [ "$_pkgname" != "$pkgname" ]; then
provides+=("$_pkgname=$pkgver")
@@ -98,7 +96,6 @@ if [ $NOEXTRACT -eq 0 ]; then
cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
- patch -Np1 -i "$srcdir/gcc47.patch" # fix to compile with gcc47
patch -Np1 -i "$srcdir/xulrunner-copy-stub.patch" # small fix
patch -Np1 -i "$srcdir/libre.patch"
fi